PAT 1096. Consecutive Factors (20)

1096. Consecutive Factors (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3*5*6*7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:

Each input file contains one test case, which gives the integer N (1<N<231).

Output Specification:

For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format "factor[1]*factor[2]*...*factor[k]", where the factors are listed in increasing order, and 1 is NOT included.

Sample Input:
630
Sample Output:
3
5*6*7

一开始想了半天,越想越复杂,后来瞄了一眼这道题的分数。。嗯。。既然只值20分,那就试试暴力破解吧!于是就用最简单的方法,从2开始连乘,一个个试过去,找到最长的。结果这样的代码就AC了。。。。代码如下:

#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
using namespace std;

int main(void)
{
	int N,max=0,temp,count;
	cin>>N;
	vector<int> result;
	vector<int> t;
	for(int i=2;i<=sqrt(N);i++)
	{
		if(N%i!=0)
			continue;
		temp=N/i;
		count=1;
		t.clear();
		t.push_back(i);
		for(int j=i+1;j<=sqrt(N);j++)
		{
			if(temp%j!=0)
				break;
			else
			{
				t.push_back(j);
				temp/=j;
				count++;
			}
		}
		if(count>max)
		{
			max=count;
			result=t;
		}
	}
	if(result.size()==0)
	{
		cout<<1<<endl<<N;
		return 0;
	}
	cout<<max<<endl;
	for(int i=0;i<result.size()-1;i++)
		cout<<result[i]<<"*";
	cout<<result[result.size()-1];
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值