PAT A1096

  • 题目:
    Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3×5×6×7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.
    Input Specification:

Each input file contains one test case, which gives the integer N (1<N<2​31​​).
Output Specification:

For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format factor[1]factor[2]…*factor[k], where the factors are listed in increasing order, and 1 is NOT included.
Sample Input:

630

Sample Output:

3
567

  • 解题思路
  • 参考:https://www.liuchuo.net/archives/2110
    分析:1、如果只有一个因子,那么这个数只能为1或者质数。因此我们主要去计算两个及以上因数的情况。
    2、在有两个及以上的数连乘中,因数的最大上限为sqrt(N) + 1
    3、因此思路就是,不断构造连乘,看连乘的积是否是N的因数,如果是,则看这部分连乘的数的个数是否比已记录的多。
    4、用变量first记录连乘的第一个数字,这里我把它赋初值为0,如果在寻找N的因数过程中,first没有改变,那么就表明N是1或者是一个质数~

代码实现:

#include<iostream>
#include<cmath>
using namespace std;
int main()
{
    long int num, temp;
    cin >> num;
    int first = 0, len = 0, maxn = sqrt(num) + 1;
    for(int i = 2; i <= maxn; i++){
        int j;
        temp = 1;
        for(j = i; j <= maxn; j++){
            temp *= j;
            if(num % temp !=0)
                break;
        }
        if(j - i > len){
            len = j- i;
            first = i;
        }
    }
    if(first == 0){
        cout << "1" << endl << num;
    } else{
        cout<< len << endl;
        for(int i = first; i < first + len;i++ ){
            if(i != first)
                cout<< "*"<<i;
            else
                cout<<i;
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值