1107. Social Clusters (30)
When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A "social cluster" is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.
Input Specification:
Each input file contains one test case. For each test case, the first line contains a positive integer N (<=1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:
Ki: hi[1] hi[2] ... hi[Ki]
where Ki (>0) is the number of hobbies, and hi[j] is the index of the j-th hobby, which is an integer in [1, 1000].
Output Specification:
For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input:8 3: 2 7 10 1: 4 2: 5 3 1: 4 1: 3 1: 4 4: 6 8 1 5 1: 4Sample Output:
3 4 3 1
又是一道Union-Find题目,代码如下:
#include <iostream>
#include <algorithm>
#include <cmath>
#include <map>
#include <set>
#include <vector>
using namespace std;
int N;
int cluster[1001]={0};
int findRoot(int x){
if(cluster[x] == x)
return x;
// cout<<"***"<<endl;
int rx = cluster[x];
while(cluster[rx]!=rx){
int rrx = findRoot(rx);
rx = rrx;
}
cluster[x] = rx;
return rx;
}
void Union(int a, int b){
int ra = findRoot(a);
int rb = findRoot(b);
cluster[rb] = ra;
}
int main(void)
{
cin>>N;
vector<int> hobbies;
vector<int> person(N);
for(int i = 1; i <= N; i++){
int number;
cin>>number;
getchar();
hobbies.clear();
hobbies.resize(number);
for(int j = 0; j < number; j++){
cin>>hobbies[j];
if(cluster[hobbies[j]] <= 0)
cluster[hobbies[j]] = hobbies[j];
}
if(hobbies.size() > 1){
for(int j = 1; j < hobbies.size(); j++){
Union(hobbies[0],hobbies[j]);
}
}
person[i-1] = findRoot(hobbies[0]);
}
set<int> count;
for(int i = 1; i <= 1000; i++){
if(cluster[i] <= 0)
continue;
int tmp = findRoot(cluster[i]);
count.insert(tmp);
}
vector<int> result(1001,0);
for(int i = 0; i < N; i++){
person[i] = findRoot(person[i]);
result[person[i]]++;
}
cout<<count.size()<<endl;
sort(result.begin(),result.end(),greater<int>());
for(int i = 0; i <= 1001; i++){
if(result[i] <= 0)
break;
if(i)
cout<<" "<<result[i];
else
cout<<result[i];
}
return 0;
}