AcWing 802.区间和

AcWing 802.区间和

题目描述

假定有一个无限长的数轴,数轴上每个坐标上的数都是 0。

现在,我们首先进行 n次操作,每次操作将某一位置 x 上的数加 c。

接下来,进行 m次询问,每个询问包含两个整数 l 和 r,你需要求出在区间 [l,r] 之间的所有数的和。

输入格式

第一行包含两个整数 n 和 m。

接下来 n行,每行包含两个整数 x 和 c。

再接下来 m
行,每行包含两个整数 l 和 r。

输出格式

共 m 行,每行输出一个询问中所求的区间内数字和。

数据范围

−10^9 ≤x≤ 10^9,
1≤n,m≤10^5,
−10^9 ≤l≤r≤ 10^9,
−10000≤c≤10000

输入样例
3 3
1 2
3 6
7 5
1 3
4 6
7 8
输出样例
8
0
5
题目思路

将所有有关的下表进行离散化处理。

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<vector>

using namespace std;

const int N = 3e5+10;

typedef pair<int,int> PII;

vector<int> alls;
vector<PII> add,query;

int a[N],s[N];

int find(int x)
{
    int l = 0,r = alls.size()-1;
    while(l < r)
    {
        int mid = l + r >> 1;
        if(alls[mid]>=x)r = mid;
        else l = mid + 1;
    }
    return l + 1;
}

int main()
{
    int n,m;
    cin >> n >> m;
    
    for(int i=0;i<n;i++)
    {
        int x,c;
        scanf("%d%d",&x,&c);
        add.push_back({x,c});
        
        alls.push_back(x);
    }
    
    for(int i=0;i<m;i++)
    {
        int l,r;
        scanf("%d%d",&l,&r);
        query.push_back({l,r});
        
        alls.push_back(l);
        alls.push_back(r);
    }
    
    sort(alls.begin(),alls.end());
    alls.erase(unique(alls.begin(),alls.end()),alls.end());
    
    for(auto item : add)
    {
        int x = find(item.first);
        a[x] += item.second; 
    }
    
    for(int i=1;i<=alls.size();i++)s[i] = a[i]+s[i-1];
    
    for(auto item : query)
    {
        int l = find(item.first),r = find(item.second);
        cout << s[r]-s[l-1] << endl;
    }
    
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

wynpz

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值