【HDU 2136】Largest prime factor(素数)

18 篇文章 0 订阅


Largest prime factor

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11955    Accepted Submission(s): 4240


Problem Description
Everybody knows any number can be combined by the prime number.
Now, your task is telling me what position of the largest prime factor.
The position of prime 2 is 1, prime 3 is 2, and prime 5 is 3, etc.
Specially, LPF(1) = 0.
 
Input
Each line will contain one integer n(0 < n < 1000000).
 
Output
Output the LPF(n).


Sample Input

1
2
3
4
5

Sample Output

0
1
2
1
3


题目大意:n的最大质因数是第几个质数

思路:筛法打表。最初先找出每个n的质因数,结果T了,后来发现打表时可以将每个数的最大质因数记录下来,数组p表示下标的最大质因数,不断更新p,最终结果就是最大的质因数。

#include<bits/stdc++.h>
#define manx 1000006
using namespace std;
int p[manx],a[manx],num[manx];
void Prime()
{
    int cot=1;
    memset(a, 1, sizeof(a));
    for (int i=2; i<=manx; i++){
        if(a[i]){
                num[i]=cot++;    //质数i的位置
                p[i]=i;
            for (int j=i+i; j<=manx; j+=i){
                p[j]=i;       //j的最大质因数
                a[j]=0;
            }
        }
    }
}
//int fun(int n)   T了
//{
//    for (int i=n; i>=2; i--)
//        if(a[i]) return i;
//}
void solve()
{
    int n;
    while(~scanf("%d",&n)){
        if(n==1) {
            printf("0\n");
            continue;
        }
        printf("%d\n",num[p[n]]);
    }
}
int main()
{
    Prime();
    solve();
    return 0;
}


暑期集训又见了这题,总觉得似曾相识啊,原来真的写过,这次简洁了一点

#include <iostream>
#include <cstdio>
#define maxn 1000006

using namespace std;

int f[maxn];
void Prime()
{
    int cot = 1;
    for (int i = 2; i < maxn; i++){
        if(!f[i]){
            f[i] = cot++;
            for (int j = i; j < maxn; j += i)
                f[j] = f[i];
        }
    }
}
int main()
{
    Prime();
    int n;
    while(~scanf("%d",&n))
        printf("%d\n",f[n]);
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值