poj 2236 Wireless NetWork

Wireless Network

Description

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B. 

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations. 

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats: 
1. "O p" (1 <= p <= N), which means repairing computer p. 
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate. 

The input will not exceed 300000 lines. 

Output

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS
 
---------------------------------------
题意 :给一些电脑的坐标,有两种操作 'O p'即修复p点 'S p q'询问p,q的是否连通;
      连通的条件是:两点之间的距离小于d,或者可以通过中间节点连接;并且两点都是修复过的;
思路:判断当前修复好的节点(是一个只有一个节点的连通分量),和之前修复好的节点(要遍历修复好的所有的节点)之间的距离D ,如果D<=d,那么就将此分量和之前节点所在的连通分量并在一起;
#include<stdio.h>
#include<string.h>
#include<math.h>
struct node
{
	int x,y;
	int pre;
}node[1010];


double dou(int x)
{
	return (x)*(x)*1.0; 
}
double distance(int x,int y,int k)
{
	return sqrt(dou(node[k].x - x) + dou(node[k].y - y));
}


int find(int k)
{
	while(k!=node[k].pre)
		k = node[k].pre;
	return k;
}
int main()
{
	int n,d;
	int i,j,k,x;
	int a[1010];//数组a用于存放所有已修复好的节点;
	char ch;
	double tmp=0;
	while(scanf("%d%d",&n,&d)!=EOF)
	{
		memset(node,0,sizeof(node));
		for(i=1;i<=n;i++)
		{
			scanf("%d%d",&node[i].x,&node[i].y);
			node[i].pre = 0;
		}
		memset(a,0,sizeof(a));
		x = 1;
		getchar();
		while(scanf("%c",&ch)!=EOF)
		{
			if(ch=='O')
			{
				scanf("%d%*c",&k);
				node[k].pre = k;//表示此点被修复好了
				for(j=1;j<x;j++)//和之前修复好的节点进行判断
				{
					tmp = distance(node[k].x,node[k].y,a[j]);
					if(tmp<=d*1.0)
					{
						int fa1,fa2;
						fa1 = find(a[j]);
						fa2 = find(k);
						if(fa1 != fa2)
							node[fa1].pre = fa2;
					}
				}
				a[x++] = k;
			}
			else if(ch=='S')
			{
				int p1,p2;
				scanf("%d%d%*c",&p1,&p2);
				if(find(p1)==find(p2))
					printf("SUCCESS\n");
				else
					printf("FAIL\n");
			}
		}
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值