hdu 3400 Line belt 三分

Line belt

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3930    Accepted Submission(s): 1528


Problem Description
In a two-dimensional plane there are two line belts, there are two segments AB and CD, lxhgww's speed on AB is P and on CD is Q, he can move with the speed R on other area on the plane.
How long must he take to travel from A to D?
 

Input
The first line is the case number T.
For each case, there are three lines.
The first line, four integers, the coordinates of A and B: Ax Ay Bx By.
The second line , four integers, the coordinates of C and D:Cx Cy Dx Dy.
The third line, three integers, P Q R.
0<= Ax,Ay,Bx,By,Cx,Cy,Dx,Dy<=1000
1<=P,Q,R<=10
 

Output
The minimum time to travel from A to D, round to two decimals.
 

Sample Input
  
  
1 0 0 0 100 100 0 100 100 2 2 1
 

Sample Output
  
  
136.60


题意:有一个线段AB,一个线段CD,有一个点从A出发,要走到D,在AB上移动速度是P,CD移动速度是Q,其他地方移动速度是R。问最短时间。

解法:三分,对线段AB进行三分,AB三分的两个点m=(l+r)/2和mm=(m+r)/2,两个点对应的最小时间lm,rm。对于m,计算lm = dis(A,m),再三分CD计算出CD某个点到m和D的时间最小值,返回给m,m点处的lm=dis(A,m)加上返回的这个值就是从A走到m点走到CD线段再走到D点的最小时间。对mm坐相同处理,值为rm。然后用求得lm和rm继续对AB进行三分求得最小时间。

#include <bits/stdc++.h>
using namespace std;
const double eps = 1e-8;

struct node{
    double x,y;
}A,B,C,D;
double P,Q,R;

double dis(node a,node b) ///两点间距离
{
    return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}

double Fd(node c,node d,node mid)  ///三分CD线段到AB某个点的最短时间
{
    node l = c,r = d,m,mm;
    double lm = 1,rm = 2;
    while(fabs(lm-rm) > eps){
        m.x = (l.x+r.x)/2;
        m.y = (l.y+r.y)/2;
        mm.x = (m.x+r.x)/2;
        mm.y = (m.y+r.y)/2;
        lm = dis(d,m)/Q+dis(m,mid)/R;   ///CD线段走的时间和其他地方走的时间
        rm = dis(d,mm)/Q+dis(mm,mid)/R;
        if(lm > rm) l = m;
        else        r = mm;
    }
    return lm;
}

int main(void)
{
    int T;
    scanf("%d",&T);
    while(T--){
        scanf("%lf%lf%lf%lf",&A.x,&A.y,&B.x,&B.y);
        scanf("%lf%lf%lf%lf",&C.x,&C.y,&D.x,&D.y);
        scanf("%lf%lf%lf",&P,&Q,&R);
        node l=A,r=B,m,mm;
        double lm=10000,rm=20000; ///随便赋个不相同的值就行了
        while(fabs(lm-rm) > eps){
            m.x = (l.x+r.x)/2;
            m.y = (l.y+r.y)/2;
            mm.x = (m.x+r.x)/2;
            mm.y = (m.y+r.y)/2;
            lm = dis(A,m)/P+Fd(C,D,m);
            rm = dis(A,mm)/P+Fd(C,D,mm);
            if(lm > rm) l = m;
            else        r = mm;
        }
        printf("%.2f\n",lm);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值