HDU 3400 Line belt

D - Line belt
Time Limit:1000MS    Memory Limit:32768KB    64bit IO Format:%I64d & %I64u

Description

In a two-dimensional plane there are two line belts, there are two segments AB and CD, lxhgww's speed on AB is P and on CD is Q, he can move with the speed R on other area on the plane.
How long must he take to travel from A to D?
 

Input

The first line is the case number T.
For each case, there are three lines.
The first line, four integers, the coordinates of A and B: Ax Ay Bx By.
The second line , four integers, the coordinates of C and D:Cx Cy Dx Dy.
The third line, three integers, P Q R.
0<= Ax,Ay,Bx,By,Cx,Cy,Dx,Dy<=1000
1<=P,Q,R<=10
 

Output

The minimum time to travel from A to D, round to two decimals.
 

Sample Input

     
     
1 0 0 0 100 100 0 100 100 2 2 1
 

Sample Output

     
     
136.60
 



在直角坐标系,给定4个点A,B,C,D;和两条直线AB,CD。

已知在AB上前进的速度是p,CD上前进的速度q,其他地方前进的速度是r..

问从A到D的最短时间。


假设在AB上有一点M,在CD上有一点N。

则最后的答案便是求。(AM)/p+(MN)/r+(ND)/q的最小值。

方法是三分。在AB和CD上三分找M,N点。直到找到最小。


#include <stdio.h>
#include <math.h>
#define EPS 1e-8
typedef struct
{
        double x,y;
}Point;
Point A,B,C,D;
double  p,q,r;
double dis(Point a,Point b)
{
        return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
double cal(Point a,Point b,Point m)
{
        Point left=a,right=b;
        Point mid,midmid;
        double ans1,ans2;
        do
        {
                mid.x=(left.x+right.x)/2.0;
                mid.y=(left.y+right.y)/2.0;
                midmid.x=(left.x+mid.x)/2.0;
                midmid.y=(left.y+mid.y)/2.0;
                ans1=dis(mid,a)/p+dis(mid,m)/r;
                ans2=dis(midmid,a)/p+dis(midmid,m)/r;
                if(ans1<ans2)
                    left=midmid;
                else
                    right=mid;
        }while(fabs(ans1-ans2)>EPS);
        return ans1;
}
int main()
{
        int t;
        scanf("%d",&t);
        while(t--)
        {
                scanf("%lf%lf%lf%lf",&A.x,&A.y,&B.x,&B.y);
                scanf("%lf%lf%lf%lf",&C.x,&C.y,&D.x,&D.y);
                scanf("%lf%lf%lf",&p,&q,&r);
                Point left=C,right=D;
                Point mid,midmid;
                double ans1,ans2;
                do
                {
                        mid.x=(left.x+right.x)/2.0;
                        mid.y=(left.y+right.y)/2.0;
                        midmid.x=(left.x+mid.x)/2.0;
                        midmid.y=(left.y+mid.y)/2.0;
                        ans1=dis(mid,D)/q+cal(A,B,mid);
                        ans2=dis(midmid,D)/q+cal(A,B,midmid);
                        if(ans1<ans2)
                                left=midmid;
                        else
                                right=mid;
                }while(fabs(ans1-ans2)>EPS);
                printf("%.2lf\n",ans1);
        }
        return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值