通用版2.R

Today the company has m tasks to complete. The ith task need xi minutes to complete. Meanwhile, this task has a difficulty level yi. The machine whose level below this task’s level yi cannot complete this task. If the company completes this task, they will get (500*xi+2*yi) dollars. 
The company has n machines. Each machine has a maximum working time and a level. If the time for the task is more than the maximum working time of the machine, the machine can not complete this task. Each machine can only complete a task one day. Each task can only be completed by one machine. 
The company hopes to maximize the number of the tasks which they can complete today. If there are multiple solutions, they hopes to make the money maximum.
InputThe input contains several test cases. 
The first line contains two integers N and M. N is the number of the machines.M is the number of tasks(1 < =N <= 100000,1<=M<=100000). 
The following N lines each contains two integers xi(0<xi<1440),yi(0=<yi<=100).xi is the maximum time the machine can work.yi is the level of the machine. 
The following M lines each contains two integers xi(0<xi<1440),yi(0=<yi<=100).xi is the time we need to complete the task.yi is the level of the task.OutputFor each test case, output two integers, the maximum number of the tasks which the company can complete today and the money they will get.Sample Input
1 2
100 3
100 2
100 1
Sample Output
1 50004
#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <string.h>
using namespace std;
struct node//把两个一样的cmp函数改成一个就AC了???
{
    int x,y;
}task[100010],mac[100010];
bool cmp(node a,node b)
{
    if(a.x>b.x)return true;
    else if(a.x==b.x){
        if(a.y>b.y)return true;
    }
    return false;
}
int main()
{
    int n,m,i,j,f[110],k;
    while(~scanf("%d%d",&n,&m)){
        for(i=0;i<=n-1;i++)scanf("%d%d",&mac[i].x,&mac[i].y);
        for(i=0;i<=m-1;i++)scanf("%d%d",&task[i].x,&task[i].y);
        sort(mac,mac+n,cmp);
        sort(task,task+m,cmp);
        memset(f,0,sizeof(f));
        int ans=0;
        long long sum=0;
        j=0;
        for(i=0;i<=m-1;i++){
            while(j<=(n-1)&&(task[i].x)<=mac[j].x){
                f[mac[j].y]++;
                 //printf("%d\n",mac[j].y);
                j++;
            }
            for(k=task[i].y;k<=100;k++){
                if(f[k]){
                    f[k]--;
                    ans++;
                    sum+=(long long)500*task[i].x+2*task[i].y;
                    break;
                }
            }
        }
        printf("%d %lld\n",ans,sum);
    }

    return 0;
}

将机器和任务都按照先时间降序后难度等级降序排列,对于任务i,在所有x>i.x的情况下找y距i.y最小的机器,那么对于任务j(j.x<i.x)一定有对应的机器可以满足它所需的时间

在找y最小的时候,因为y<100,可以用一个升序遍历找

这个题蛮好的,可以再看看

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值