通用版2.U

A set of n 1-dimensional items have to be packed in identical bins. All bins have exactly the same length l and each item i has length li<=l . We look for a minimal number of bins q such that 
  • each bin contains at most 2 items, 
  • each item is packed in one of the q bins, 
  • the sum of the lengths of the items packed in a bin does not exceed l .

You are requested, given the integer values n , l , l1 , ..., ln , to compute the optimal number of bins q . 
Input
The first line of the input contains the number of items n (1<=n<=10 5) . The second line contains one integer that corresponds to the bin length l<=10000 . We then have n lines containing one integer value that represents the length of the items.
Output
Your program has to write the minimal number of bins required to pack all items.
Sample Input
10
80
70
15
30
35
10
80
20
35
10
30
Sample Output
6
Hint
The sample instance and an optimal solution is shown in the figure below. Items are numbered from 1 to 10 according to the input order. 
#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
int s[100010];
int main()
{
    int n,l,i,j,ans=0;
    scanf("%d%d",&n,&l);
    for(i=0;i<=n-1;i++){
        scanf("%d",&s[i]);
    }
    sort(s,s+n);
    //for(i=0;i<=n-1;i++)printf("%d,",s[i]);
    i=0;
    j=n-1;
   // printf("\n\n");
    while(i<j){
        while(s[i]+s[j]>l){
            ans++;
            j--;
        }
        //printf("%d,%d\n",s[i],s[j]);
        ans++;
        i++;
        j--;
        if(i==j)ans++;
    }
    printf("%d\n",ans);
    return 0;
}

题意大概是有n个道具,第i个道具长Li,有箱子可以装这些道具,每个箱子最多装两个道具,箱子本身有长度l,问把这些道具装完最少需要多少箱子

先给长度由小到大排个序,小的尽量和大的结合,如果大的找不到结合的就独自装一个箱子里。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值