Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is "yes", if 6 is a decimal number and 110 is a binary number.
Now for any pair of positive integers N1 and N2, your task is to find the radix of one number while that of the other is given.
Input Specification:
Each input file contains one test case. Each case occupies a line which contains 4 positive integers:
N1 N2 tag radix
Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set {0-9, a-z} where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number "radix" is the radix of N1 if "tag" is 1, or of N2 if "tag" is 2.
Output Specification:
For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print "Impossible". If the solution is not unique, output the smallest possible radix.
Sample Input 1:6 110 1 10Sample Output 1:
2Sample Input 2:
1 ab 1 2Sample Output 2:
Impossible
#include<stdio.h>
#include<algorithm>
#include<math.h>
#include<iostream>
#include<string.h>
#include<vector>
#include<queue>
#include<string>
using namespace std;
//在一种进制下使二者值相等
//从最小的进制向上枚举,如果都不可能则输出impossible
//10位,每个最大为35,
//题的本质:求一个n次方程(《=10)的整数解
int getnum(char a){
return a>='0' && a<='9' ? a-'0' : a-'a'+10;
}
long long int todecimal(char a[],long long int radix){//存在大数据,不能用int保存,溢出时返回
int len=strlen(a);
long long int ans=0;
for(int i=0;i<len;i++){
ans*=radix;
ans+=getnum(a[i]);
if(ans<0) return -1;
}
return ans;
}
int main(){
char buf1[15],buf2[15];
long long int id,radix,minradix=0,maxradix;
scanf("%s %s %lld%lld",buf1,buf2,&id,&radix);
/*
最小的基>所有位数中的最大值
最大的基只要比数能表示的最大值大即可
不论是1,2默认对2处理
*/
char temp[15];
if(id==2){
strcpy(temp,buf2);
strcpy(buf2,buf1);
strcpy(buf1,temp);
}
int max=0;
for(int i=0;i<strlen(buf2);i++){
if(getnum(buf2[i])>max)
max=getnum(buf2[i]);
}
long long int value=todecimal(buf1,radix);
minradix=max+1;
maxradix=value+1;
//注意是35^10级别的,要用二分搜索
//只有一位数时才有无穷解(费马定理)
//本质:用二分法解 a(i)*radix^i=A;
long long int radix2;
while(minradix<=maxradix){
radix2=(minradix+maxradix)/2;
long long int ans=todecimal(buf2,radix2);
if(ans<value)
minradix=radix2+1;
else if(ans>value || ans==-1)
maxradix=radix2-1;
else {
cout<<radix2;
return 0;
}
}
cout<<"Impossible";
return 0;
}