1015. Reversible Primes

reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (< 105) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line "Yes" if N is a reversible prime with radix D, or "No" if not.

Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes

No

注意的地方:1.题目给的是十进制,要在给定的进制下进行转换,求反,对得到的结果转为十进制,也可一步完成

即:把n进制转10进制和10进制转n进制的和在一起;

2.注意1不是质数,也不是合数

#include<stdio.h>
#include<algorithm>
#include<math.h>
#include<iostream>
#include<string.h>
#include<vector>
#include<queue>
#include<string>
#include<map>
/*
	题目给的是十进制数,要求在某种进制下进行转换,再对结果翻转,求其十进制,然后判断是否仍为素数
*/
bool isprime(int x){
	if(x==1)	return false;
	for(int i=2;i*i<x+1;i++)
		if(x%i==0)	return false;
	return true;
}
int toreverse(int n,int radix){
	int ret=0;
	do{
		ret*=radix;
		ret+=n%radix;
		n/=radix;
	}while(n!=0);
	return ret;
}
int main(){
	int n,d;
	while(true){
		scanf("%d",&n);
		if(n<0)	return 0;
		else{
			scanf("%d",&d);
			if(isprime(n) && isprime(toreverse(n,d)))
				printf("Yes\n");
			else printf("No\n");
		}
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值