【PAT甲级】1015 Reversible Primes 转进制逆序后判素数

【题意】

给一个十进制数n,和一个进制数d,如果n为质数,那么将n转为d进制数,然后反序该数,再转回十进制,最后判该数是否仍为质数;给多组数判别,当输入出现负数时终止输入条件判别。

【原题链接】

reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<10​5​​) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

【题解】 

思路一:

首先判给的数n是质数否,不是的话直接No;是的话模拟要求的操作,然后判断即可。

特别的是y总的方法,将原十进制数从低位转d进制数(为反转数准备),接着转回十进制(累加进位res*d过程中实现转回10进制与d进制数的反转),高效的一步实现转d进制→反转→转回10进制的同样效果。

#include <iostream>
#include <cstring>
using namespace std;

bool is_prime(int a){  //判质数
    if(a==1) return false;
    for(int i=2;i*i<=a;i++){
        if(a%i==0) return false; 
    }
    return true;
}

bool check(int n,int d){  //处理判别
    long long res=0;
    if(!is_prime(n)) return false;  //一开始就不是质数,就直接返回false
    while(n){
        res=res*d+n%d;  //将原十进制数从低位转d进制数,接着转回十进制;高效实现转d进制→反转→转回10进制的过程
        n/=d;
    }
    return is_prime(res);
}

int main(){
	int n,d;
	while(cin>>n>>d,n>=0){  //逗号表达式,根据逗号后面的判别
	    if(!check(n,d)) cout<<"No"<<endl;
	    else cout<<"Yes"<<endl;
	}  
	
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值