A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:
The left subtree of a node contains only nodes with keys less than the node's key.The right subtree of a node contains only nodes with keys greater than or equal to the node's key.Both the left and right subtrees must also be binary search trees.Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (<=100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format "left_index right_index", provided that the nodes are numbered from 0 to N-1, and 0 is always the root. If one child is missing, then -1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.
Output Specification:
For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.
Sample Input:9 1 6 2 3 -1 -1 -1 4 5 -1 -1 -1 7 -1 -1 8 -1 -1 73 45 11 58 82 25 67 38 42Sample Output:
58 25 82 11 38 67 45 73 42
#include<stack>
#include<vector>
#include<iostream>
#include<algorithm>
#include<math.h>
#include<queue>
using namespace std;
//建立相应的树形,将权值排序后按中序遍历放入,最后进行层次遍历
struct node{
int lchild,rchild,data;
}tree[120];
int n,buf[120];
int index=0;
void inorder(int root){
if(root==-1) return;
inorder(tree[root].lchild);
tree[root].data=buf[index++];
inorder(tree[root].rchild);
}
void layer(){
queue<int> q;
q.push(0);
int cnt=0;
while(!q.empty()){
int v=q.front();
q.pop();
cnt++;
if(cnt!=n) cout<<tree[v].data<<" ";
else cout<<tree[v].data<<endl;
if(tree[v].lchild!=-1) q.push(tree[v].lchild);
if(tree[v].rchild!=-1) q.push(tree[v].rchild);
}
}
int main()
{
cin>>n;
for(int i=0;i<n;i++){
cin>>tree[i].lchild>>tree[i].rchild;
}
for(int i=0;i<n;i++)
cin>>buf[i];
sort(buf,buf+n);
inorder(0);
layer();
return 0;
}