「1099」Build A Binary Search Tree

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node’s key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
  • Both the left and right subtrees must also be binary search trees.

Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

figBST.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format left_index right_index, provided that the nodes are numbered from 0 to N−1, and 0 is always the root. If one child is missing, then −1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output Specification:

For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42

Sample Output:

58 25 82 11 38 67 45 73 42

Ω

给出二叉搜索树(BST)的结构与一个无序数组 ,输出将这个数组放入该结构BST的层次遍历结果。

很显然,我们只要知道了BST中每个节点在排序结果中的序号即可,比如最左边的节点是最小的,因此排序序号为0,根据BST的性质可知排序序号就是左子树的节点个数。那么我们对BST进行中序遍历就能得到每个节点的排序序号,再对 进行排序,根据在排序序列中的序号放入相应的BST节点,最后BFS遍历输出节点即可。


🐎

#include <iostream>
#include <vector>
#include <algorithm>

using namespace std;
vector<int> idx; // sort index
vector<pair<int, int>> son;

void make_idx(int r) // In-Order Traversal
{
    static int i = 0;
    if (son[r].first != -1)
        make_idx(son[r].first);
    idx[r] = i++;
    if (son[r].second != -1)
        make_idx(son[r].second);
}

int main()
{
    int n;
    cin >> n;
    son.resize(n);
    for (auto &s: son)
        cin >> s.first >> s.second;
    idx.resize(n);
    make_idx(0);
    vector<int> seq(n);
    for (auto &k: seq)
        cin >> k;
    sort(seq.begin(), seq.end());
    vector<int> crt{0}, nxt;
    cout << seq[idx[0]];
    do
    {
        for (auto &k: crt)
        {
            if (son[k].first != -1) nxt.push_back(son[k].first);
            if (son[k].second != -1) nxt.push_back(son[k].second);
        }
        for (auto &k: nxt)
            cout << " " << seq[idx[k]];
        crt = std::move(nxt);
        nxt = vector<int>();
    } while (!crt.empty());
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值