hdu 2119 Matrix

Matrix

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1741    Accepted Submission(s): 745


Problem Description
Give you a matrix(only contains 0 or 1),every time you can select a row or a column and delete all the '1' in this row or this column .

Your task is to give out the minimum times of deleting all the '1' in the matrix.
 

Input
There are several test cases.

The first line contains two integers n,m(1<=n,m<=100), n is the number of rows of the given matrix and m is the number of columns of the given matrix.
The next n lines describe the matrix:each line contains m integer, which may be either ‘1’ or ‘0’.

n=0 indicate the end of input.
 

Output
For each of the test cases, in the order given in the input, print one line containing the minimum times of deleting all the '1' in the matrix.
 

Sample Input
  
  
3 3 0 0 0 1 0 1 0 1 0 0
 

Sample Output
  
  
2
 
分析:
1. 行,列(一整行,一整列)拆分成 X,Y集合,编号1-n 和 1-m。
2. 某一行列相交有1时,X集合行编号和Y集合相应编号建立连接关系。
   这时二分图的边就对应原图中的1,转化成求最小点覆盖,就是求最大匹配(最小点覆盖数=最大匹配数)


<span style="font-size:18px;">#include<stdio.h>
#include<iostream>
using namespace std;
#define Max 1000

int map[Max][Max];
int flag[Max];
int match[Max];
int n,m;

int find(int x)
{
	int j;
	for(j=1;j<=m;j++)
	{
	  if(map[x][j] && flag[j]==0)
	  {
	    flag[j]=1;
		if(match[j]==-1||find(match[j]))
		{
		  match[j]=x;
		  return 1;
		}
	  }
	}
	return 0;
}


int main ()
{
	int i,j;
	while(~scanf("%d",&n)&&n!=0)
	{  
	    scanf("%d",&m);
		memset(match,-1,sizeof(match));
		for(i=1;i<=n;i++)
		{ 
			for(j=1;j<=m;j++)
				scanf("%d",&map[i][j]);
		}
		int sum=0;
		for(i=1;i<=n;i++)
		{
			memset(flag,0,sizeof(flag));
			if(find(i))
				sum++;
		}
		printf("%d\n",sum);
	}
	return 0;
}</span>


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值