HDU6225 Little Boxes【大数 Python、Java】

原题链接:Little Boxes

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 2542    Accepted Submission(s): 918


 

Problem Description

Little boxes on the hillside.
Little boxes made of ticky-tacky.
Little boxes.
Little boxes.
Little boxes all the same.
There are a green boxes, and b pink boxes.
And c blue boxes and d yellow boxes.
And they are all made out of ticky-tacky.
And they all look just the same.

 

 

Input

The input has several test cases. The first line contains the integer t (1 ≤ t ≤ 10) which is the total number of test cases.
For each test case, a line contains four non-negative integers a, b, c and d where a, b, c, d ≤ 2^62, indicating the numbers of green boxes, pink boxes, blue boxes and yellow boxes.

 

 

Output

For each test case, output a line with the total number of boxes.

 

 

Sample Input

 

4 1 2 3 4 0 0 0 0 1 0 0 0 111 222 333 404

 

 

Sample Output

 

10 0 1 1070

 

 

Source

2017ACM/ICPC亚洲区沈阳站-重现赛(感谢东北大学)

 

 

Recommend

jiangzijing2015

 

 

Python:

# HDU6225 UVALive8209 Little Boxes
 
n = int(input())
for i in range(0, n):
    a,b,c,d = map(int, input().split())
    print(a + b + c + d)

Java:

# HDU6225 UVALive8209 Little Boxes

import java.math.BigInteger;
import java.util.Scanner;
 
public class Main {
    public static Scanner s = new Scanner(System.in);
 
    public static void main(String args[]) throws Exception {
	Scanner in = new Scanner(System.in);
        int t = in.nextInt();
        while(t-- != 0) {
            BigInteger a = in.nextBigInteger();
            BigInteger b = in.nextBigInteger();
            BigInteger c = in.nextBigInteger();
            BigInteger d = in.nextBigInteger();
            System.out.println(a.add(b.add(c.add(d))));
        }
 
    }
}

c++解法:HDU6225 Little Boxes【大数 C++】

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值