HDU 6225 Little Boxes

题目描述

Problem Description
Little boxes on the hillside.
Little boxes made of ticky-tacky.
Little boxes.
Little boxes.
Little boxes all the same.
There are a green boxes, and b pink boxes.
And c blue boxes and d yellow boxes.
And they are all made out of ticky-tacky.
And they all look just the same.

Input
The input has several test cases. The first line contains the integer t (1 ≤ t ≤ 10) which is the total number of test cases.
For each test case, a line contains four non-negative integers a, b, c and d where a, b, c, d ≤ 2^62, indicating the numbers of green boxes, pink boxes, blue boxes and yellow boxes.


Output
For each test case, output a line with the total number of boxes.


Sample Input
4
1 2 3 4
0 0 0 0
1 0 0 0
111 222 333 404


Sample Output
10
0
1
1070

这个题看似简单..实则有大坑,在题干信息中描述很清楚,为4个数字的加法求和,但是如果没有注意到数据范围,就会轻易地交出一血

以下是错误示范:

int n;
    cin>>n;
    ll a[100];
    while(n--){
        ll ans=0;
        for(int i=0;i<4;i++){
            cin>>a[i];
            ans+=a[i];
        }
        cout<<ans<<endl;
    }

这个结果很明显,每个数字的数据上限是2^62次方,四个的话就是2^64次方,而ll的数据上限是2^63-1,由于题干信息可以理解数据不会出现负数,所以我们用unsigned long long 解决数据上限问题,于是二血也被交出去了…

    int n;
    cin>>n;
    ull a[100];
    while(n--){
        ull ans=0;
        for(int i=0;i<4;i++){
            cin>>a[i];
            ans+=a[i];
        }
        cout<<ans<<endl;
    }

可惜的是比赛的时候没动脑子,unsigned long long 的数据范围是2^64-1,没有包括最极端的情况,所以需要特判一下,这次就算对了..水题也不能掉以轻心啊

Ac代码如下:

    #include<cstdio>
    #include<cstdlib>
    #include<cmath>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    #include<queue>
    #include<map>
    #include<stack>
    #include<set>
    using namespace std;
    typedef long long ll;
    typedef unsigned long long ull;
    const int MAX_N=100000;
    ull a[100];
    int main()
    {
        ios::sync_with_stdio(false);
        int n;
        cin>>n;
        while(n--){
            ull ans=0;
            for(int i=0;i<4;i++){
                cin>>a[i];
                ans+=a[i];
            }
            if(a[1]==4611686018427387904&&a[2]==4611686018427387904&&a[3]==4611686018427387904&&a[0]==4611686018427387904)
                cout<<"18446744073709551616"<<endl;
            else
                cout<<ans<<endl;
        }

        return 0;
    }
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值