POJ 1470 Closest Common Ancestors

Closest Common Ancestors

Description

Write a program that takes as input a rooted tree and a list of pairs of vertices. For each pair (u,v) the program determines the closest common ancestor of u and v in the tree. The closest common ancestor of two nodes u and v is the node w that is an ancestor of both u and v and has the greatest depth in the tree. A node can be its own ancestor (for example in Figure 1 the ancestors of node 2 are 2 and 5)
Input

The data set, which is read from a the std input, starts with the tree description, in the form:

nr_of_vertices
vertex:(nr_of_successors) successor1 successor2 ... successorn
...
where vertices are represented as integers from 1 to n ( n <= 900 ). The tree description is followed by a list of pairs of vertices, in the form:
nr_of_pairs
(u v) (x y) ...

The input file contents several data sets (at least one).
Note that white-spaces (tabs, spaces and line breaks) can be used freely in the input.
Output

For each common ancestor the program prints the ancestor and the number of pair for which it is an ancestor. The results are printed on the standard output on separate lines, in to the ascending order of the vertices, in the format: ancestor:times
For example, for the following tree:

Sample Input

5
5:(3) 1 4 2
1:(0)
4:(0)
2:(1) 3
3:(0)
6
(1 5) (1 4) (4 2)
(2 3)
(1 3) (4 3)
Sample Output

2:1
5:5
Hint

Huge input, scanf is recommended.



#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#define maxn 1000
using namespace std;

int n ;
bool indegree[maxn] ;                               //入度
vector<int> tree[maxn] , que[maxn] ;            
int fa[maxn] , visit[maxn] , num[maxn];         

void init() {
    for( int i = 1 ;i <= n ; ++i ) {
        visit[i] = 0 ;
        indegree[i] = 0 ;
        tree[i].clear() ;
        que[i].clear() ;
        num[i] = 0 ;
    }
}

int findd(int r) {
    return r == fa[r] ? fa[r] : findd(fa[r]) ;   //并查集查找  压缩路径
}

void lca( int u ) {
    fa[u] = u;
    int sizee = tree[u].size() ;
    for(int i = 0 ; i < sizee ; ++i) {           // 访问父结点的孩子
        lca(tree[u][i]) ;
        fa[tree[u][i]] = u ;                     // 记录孩子父亲
    }

    visit[u] = 1 ;                              // 标记访问结点
    sizee = que[u].size() ;
    for ( int i = 0 ; i < sizee ; ++i ) {       // 查询该节点的提问
        if( visit[que[u][i]])
            ++num[findd(que[u][i])] ;           // 找最近公共祖先 , 并记录个数
    }
}

int main() {
    while(~scanf("%d",&n)) {
        init() ;
        int  son ,root , ncase ;
        for ( int i = 1 ; i <= n; ++i ){
            scanf("%d:(%d) ",&root, &ncase) ;
            while( ncase-- ){
                scanf("%d",&son ) ;
                tree[root].push_back(son) ;
                ++indegree[son] ;
            }
        }
        int text ;
        int left , right ;
        scanf("%d",&text);
        while( text-- ) {
                scanf(" (%d%d)",&left,&right) ;      
                que[left].push_back(right) ;        
                que[right].push_back(left) ;        // 有效查询有且仅有一次 
            }
        for( int i = 1 ; i <= n ; ++i ){            // 找树根 , 入度为0
            if(!indegree[i]) {
                lca(i) ;
                break ;
            }
        }
        for( int i = 1 ; i <= n ; ++i ) {
            if( num[i] ) {
                printf("%d:%d\n",i,num[i]) ;
            }
        }
    }
    return 0 ;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值