POJ 2533 Longest Ordered Subsequence

Longest Ordered Subsequence
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 39246 Accepted: 17258
Description

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence (a1, a2, ..., aN) be any sequence (ai1, ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.
Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000
Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.
Sample Input

7
1 7 3 5 9 4 8
Sample Output

4
Source

Northeastern Europe 2002, Far-Eastern Subregion

题意:求最长上升子序列 经典题

思路:基础DP 。 提供时间复杂度O(n^2) 和O(n*logn) 两种。

第一种是记忆化搜索,浅显易懂。

第二种值得学习。开辟一个栈数组。输入now,若now>stack[top] ,加入之,否则,2分查找(优化)第一个不小于的mid值,替换之。

从而保证栈数组内的单调性,top值即为所求。

记忆化搜索dp

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std ;
const int maxn = 1000 + 100 ;
const int inf = 1<<30 ;
int a[maxn] ;
int num[maxn] ;
int temp , maxx , n ;
int dp( int p ) {
    int& ans = num[p] ;
    if(ans > 0 ) return ans ;
    for( int i = p+1 ;i < n ; ++i ) {
        if( a[i] > a[p] ) {
            ans = max( ans , dp(i)+1)  ;
        }
    }
    return ans ;
}
int main() {
    while(~scanf("%d",&n)){
        for( int i = 0 ; i < n ; ++i  ) {
            scanf("%d",&a[i]) ;
        }
        temp  , maxx = -inf ;
        memset(num,0,sizeof(num)) ;
        for( int i = 0 ; i < n ; ++i ) {
            if( (temp = dp(i)+1) > maxx ) maxx = temp ;
        }
        cout << maxx << endl ;
    }

    return 0 ;
}
二分优化dp

#include <iostream>
#include <cstdio>
using namespace std;

int main()
{
    int i , j  , n , top , temp ;
    int stack[1100] ;
    while(~scanf("%d",&n))
    {
        top = 0;
        stack[0] = -1 ;
        for ( int i= 0 ;i < n ; ++i)
        {
            scanf("%d",&temp) ;
            if( temp > stack[top] )
            {
                stack[++top] = temp ;
            }
            else {
                int low = 1 , high = top ;
                int mid  ;
                while( low<= high)
                {
                    mid = (low + high)/2 ;
                    if( stack[mid] < temp)
                    {
                        low = mid + 1 ;
                    }
                    else
                    {
                        high = mid -1 ;
                    }
                }
                stack[low] = temp ;

                }
        }
        printf("%d\n",top) ;
    }


    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值