Longest Ordered Subsequence
Time Limit: 2000MS | Memory Limit: 65536K | |
Total Submissions: 47568 | Accepted: 21167 |
Description
A numeric sequence of
ai is ordered if
a1 <
a2 < ... <
aN. Let the subsequence of the given numeric sequence (
a1,
a2, ...,
aN) be any sequence (
ai1,
ai2, ...,
aiK), where 1 <=
i1 <
i2 < ... <
iK <=
N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).
Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.
Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.
Input
The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000
Output
Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.
Sample Input
7 1 7 3 5 9 4 8
Sample Output
4
找出最长的递增序列,暴力dp
Source
#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
int main()
{
int n;
int dp[1010];
int num[1010];
while(scanf("%d",&n)==1)
{
int maxn=1;
for(int i=1; i<=n; i++)
{
scanf("%d",&num[i]);
dp[i]=1;
}
for(int i=2; i<=n; i++)
{
for(int j=1; j<i; j++)
{
if(num[i]>num[j])
dp[i]=max(dp[j]+1,dp[i]);
}
maxn=max(maxn,dp[i]);
}
cout<<maxn<<endl;
}
return 0;
}