Wine trading in Gergovia

Wine trading in Gergovia

Time Limit: 1000MS Memory limit: 65536K

题目描述

There is one problem, however: Transporting wine from one house to another results in work. Since all wines are equally good, the inhabitants of Gergovia don\'t care which persons they are doing trade with, they are only interested in selling or buying a specific amount of wine. They are clever enough to figure out a way of trading so that the overall amount of work needed for transports is minimized.

In this problem you are asked to reconstruct the trading during one day in Gergovia. For simplicity we will assume that the houses are built along a straight line with equal distance between adjacent houses. Transporting one bottle of wine from one house to an adjacent house results in one unit of work.

输入

  n  (2 ≤   n  ≤ 100000). The following line contains n integers a i  (-1000 ≤ a i  ≤ 1000). If a i  ≥ 0, it means that the inhabitant living in the i th  house wants to buy a i  bottles of wine, otherwise if a i  < 0, he wants to sell -a i  bottles of wine. You may assume that the numbers a i  sum up to 0.
The last test case is followed by a line containing 0.

输出


示例输入

5
5 -4 1 -3 1
6
-1000 -1000 -1000 1000 1000 1000
0

示例输出

9
9000

 

#include <stdio.h>   
#include <stdlib.h>   
int main()   
{   
    int a[100001],i,n;   
    long long sum;   
    while(~scanf("%d",&n)&&n!=0)   
    {   
        sum=0;   
       for(i=0;i<n;i++)   
       {   
           scanf("%d",&a[i]);   
       }   
       for(i=0;i<n;i++)   
       {   
           if(a[i]>0)   
           {   
               sum=sum+a[i];   
               a[i+1]=a[i+1]+a[i];   
           }   
           if(a[i]<0)   
           {   
               sum=sum-a[i];   
               a[i+1]=a[i+1]+a[i];   
           }   
       }   
       printf("%lld\n",sum);   
    }   
}   


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值