This version of the rendering library is more recent than your version of ADT plug-in. Please update


地址:http://stackoverflow.com/questions/18852983/eclipse-reports-rendering-library-more-recent-than-adt-plug-in

This version of the rendering library is more recent than your version of ADT plug-in. Please update


互相学习,请关注我的微博weibo.com/ganchaojiang 


预览layout.xml文件时提示:

This version of the rendering library is more recent than your version of ADT plug-in. Please update ADT plug-in

导致无法正常预览布局文件;

问题根源:SDK版本过高,ADT版本低;

解决办法有好几种,如下:

1.

  1. Click Help > Install New Software.
  2. In the Work with field, enter: https://dl-ssl.google.com/android/eclipse/
  3. Select Developer Tools / Android Development Tools.
  4. Click Next and complete the wizard. 

2.


Change android version while rendering layout.



3,

Change the Target version to new updates you have. Otherwise, change what SDK version you have in the Android manifest file.

android:minSdkVersion="8"
android:targetSdkVersion="18"

没有更多推荐了,返回首页