C - Prime Ring Problem(深度搜索)

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

 

Input

n (0 < n < 20).

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input

6
8

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

 

 

本题目大体的意思就是相邻的两个数相加起来要是素数

思路:就是深度搜索

 

c++代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>                                                        
using namespace std;
int n, t;
bool book[26];//用来表示说明那些数字是否被用了 0表示没有被用;
int digit[26];
bool prime[26];//布尔格被默认为0;

void show()
{
    int i;
    for(i=1;i<=n-1;i++)
    printf("%d ",digit[i]);
    printf("%d\n",digit[n]);
}//输出结束  

void isprime()
{
     for(int i=2;i<=25;i++)
     {
        if(!prime[i])
        {
            for(int j=2;i*j<=25;j++)
            prime[i*j]=1;
        }    
     }    
}//把素数都筛选出来;  
    //  1     出现了素数越界的问题  

void dfs(int num)
{
    if(num==n)         
    {
        if(!prime[digit[1]+digit[n]])
        {
            show();
        }    
        return;
    }     
    //   2   无论怎样子都是要返回的;
    for(int i=2;i<=n;i++)
    {
        if(book[i]==0&&!prime[i+digit[num]])//book[i]=0表示说还没有被用
        {
           book[i]=1;
           digit[num+1]=i;
           dfs(num+1);
           book[i]=0;     
        }//3   这个地方是要注意的   因为如果把book[i]放在外面的话就 容易造成说 在递归的时候也用这个所以尽量的避免
    }
    return;
}
int main()
{
    isprime();
    t = 1;
    while(~scanf("%d",&n))
    {
        memset(book,false,sizeof(book));
        book[1]=1;//表示1已经被用了;
        digit[1]=1; //表示说输出的时候1是在第一个的;
        printf("Case %d:\n",t);
        t++;
        dfs(1);
        printf("\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值