搜索 C - Prime Ring Problem

   A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


Input n (0 < n < 20).
Output The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
Sample Input
6
8
Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2

1 6 7 4 3 8 5 2

分析:

1.题目表达的意思是,相邻两个圈内的数字之和为素数。

2.重要的一点一定要注意,dfs里面最后出口的判断条件,一定要有Issu(a[1]+a[n]),最后一个和第一个也是要判断的。

3.还要注意题目的格式要求;每一组输出后,都会先输出一个回撤,接着才是数据的输出。(Print a blank line after each case.)



#include<algorithm>
#include<iostream>
#include<cstring>
#include<math.h> 
using namespace std;
int num[1002];
int v[1002];
int n;
int Issu(int x)
{
if(x<2)
 return 0;
for(int i=2;i<=sqrt(x);i++)
{
if(x%i==0)
{
return 0;
}
}
return 1;
}
void dfs(int s)
{
if(s==n&&Issu(num[1]+num[n])){
for(int i=1;i<n;i++)
 cout<<num[i]<<" ";
cout<<num[n]<<endl;
}
for(int i=2;i<=n;i++)
{
if(!v[i]&&Issu(num[s]+i))
{
num[s+1]=i;
v[i]=1;
dfs(s+1);
v[i]=0;
}
}
}
int main()
{
    int t=1;
while(cin>>n){
memset(v,0,sizeof(v));
num[1]=1;
cout<<"Case "<<t<<":"<<endl;
  t++;
dfs(1);
cout<<endl;
}
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值