非常可乐(广度搜索)

非常可乐:
大家一定觉的运动以后喝可乐是一件很惬意的事情,但是seeyou却不这么认为。因为每次当seeyou买了可乐以后,阿牛就要求和seeyou一起分享这一瓶可乐,而且一定要喝的和seeyou一样多。但seeyou的手中只有两个杯子,它们的容量分别是N 毫升和M 毫升 可乐的体积为S (S<101)毫升 (正好装满一瓶) ,它们三个之间可以相互倒可乐 (都是没有刻度的,且 S==N+M,101>S>0,N>0,M>0) 。聪明的ACMER你们说他们能平分吗?如果能请输出倒可乐的最少的次数,如果不能输出"NO"。

 

Input

三个整数 : S 可乐的体积 , N 和 M是两个杯子的容量,以"0 0 0"结束。

Output

如果能平分的话请输出最少要倒的次数,否则输出"NO"。

Sample Input

7 4 3
4 1 3
0 0 0

Sample Output

NO
3

 

规律:

import java.util.Scanner;
import java.util.Arrays;
public class Hello {
	static Scanner sc = new Scanner(System.in);
	static int total,n,m;
	static int gcd(int n,int m) {
		if(m == 0 )
			return n;
		else 
			return gcd(m, n % m);
	}
	public static void main(String[] args) {
		while(sc.hasNext())
		{
			total = sc.nextInt();
			n = sc.nextInt();
			m = sc.nextInt();
			if(total == 0 && n == 0 && m == 0)
				System.exit(0);
			total = total / gcd(n,m);
			if(total % 2 == 1) 
				System.out.println("NO");
			else 
				System.out.println(total - 1);
		}
	}
}

 

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<queue>
#include<cstring>
using namespace std;
int b[3],half;
int book[102][102][102];
struct node
{
	int cur[3];
	int s;
};
void BFS()
{
	queue<node>qu;
	node tmp;
	tmp.cur[0]=b[0];
	tmp.cur[1]=tmp.cur[2]=tmp.s=0;
	qu.push(tmp);
	while(qu.empty()==0)
	{
		node yy=qu.front();
		qu.pop();
		for(int i=0;i<3;i++)
		{
			if(yy.cur[i]>0)
			{
				for(int j=0;j<3;j++)
				{
					if(i==j)continue;
					tmp=yy;
					if(tmp.cur[i]>=(b[j]-tmp.cur[j]))
					{
					   	tmp.cur[i]=tmp.cur[i]-(b[j]-tmp.cur[j]);
					   	tmp.cur[j]=b[j];
					}else 
					{
						tmp.cur[j]=tmp.cur[i]+tmp.cur[j];
						tmp.cur[i]=0;
					} 
					if(book[tmp.cur[0]][tmp.cur[1]][tmp.cur[2]]==1)
					continue;
					else 
					{
						if(tmp.cur[0]==half&&tmp.cur[1]==half||tmp.cur[0]==half&&tmp.cur[2]==half
						||tmp.cur[2]==half&&tmp.cur[1]==half)
	                    {
	                    	printf("%d\n",yy.s+1);
	                    	return;
	                    }       
						book[tmp.cur[0]][tmp.cur[1]][tmp.cur[2]]=1;
						tmp.s=yy.s+1;
						qu.push(tmp);
					}
				}		
			}
		}	
	}
	printf("NO\n");
	return;
}
int main()
{
    while(scanf("%d%d%d",&b[0],&b[1],&b[2])!=EOF)
	{
		if(b[0]==0&&b[1]==0&&b[2]==0)
		break;
		 if(b[0]%2==1)
		 {
		 	printf("NO\n");
		 	continue;
		 }	
		 memset(book,0,sizeof(book));
		 book[b[0]][b[1]][b[2]]=1;
		 half=b[0]/2;
		 BFS();
	}
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值