K - 迷宫问题 POJ - 3984(广度搜索)


定义一个二维数组:
int maze[5][5] = {

	0, 1, 0, 0, 0,

	0, 1, 0, 1, 0,

	0, 0, 0, 0, 0,

	0, 1, 1, 1, 0,

	0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
Input
一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
Output
左上角到右下角的最短路径,格式如样例所示。
Sample Input
0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
Sample Output
(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

嘿嘿,继上一题之后开心了一丢丢,虽然很简单~~~~

代码:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <queue>
#include <stack>
using namespace std;
struct Node{
    int x,y;
};
struct Pass{
    int x,y;
}s[8][8];
struct ST{
    int m,n;
};
int dirx[4]={1,-1,0,0};
int diry[4]={0,0,1,-1};
int maze[8][8],book[8][8];//刚开始的初始化为0
void BFS()
{
    Node beginn ={0,0};//设置开始的那个位置为1,1;
	queue<Node>mq;
    mq.push(beginn);
    s[0][0].x=-1;
    s[0][0].y=-1;
    book[0][0]=1;
    Node temp,endd;
    while(mq.empty()==0)
    {
        temp=mq.front();
        mq.pop();
        for(int i=0;i<4;i++)
        {
            int fx=temp.x+dirx[i];
            int fy=temp.y+diry[i];
            if(fx<0||fy<0||fx>4||fy>4||book[fx][fy]==1||maze[fx][fy]==1)continue;
            else
            {
     		    endd.x=fx;
            	    endd.y=fy;
	            book[fx][fy]=1;
	            s[fx][fy].x=temp.x;
	            s[fx][fy].y=temp.y;
	            mq.push(endd);
	            if(endd.x==4&&endd.y==4) break;       	
	    }
        }
    }
}
int main()
{
	for(int i=0;i<5;i++)
	{
	    for(int j=0;j<5;j++)
            scanf("%d",&maze[i][j]);
	}//读入
	BFS();
/*	for(int i=0;i<5;i++)
	{
	    for(int j=0;j<5;j++)
            printf("%d %d==      ",s[i][j].x,s[i][j].y);
            cout<<endl;
	}
*/
	stack<ST>ss;
	ST gg;gg.m=4,gg.n=4;
	ss.push(gg);
	int a=4,b=4;
	while(a!=-1&&b!=-1){
	    gg.m=s[a][b].x;
	    gg.n=s[a][b].y;
	    ss.push(gg);
	    int gg=a,kk=b;
	    a=s[gg][kk].x;
	    b=s[gg][kk].y;
	}
	ss.pop();
	while(ss.empty()==0)
	{
	    gg=ss.top();
	    ss.pop();
	    printf("(%d, %d)\n",gg.m,gg.n); 
	}
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
根据提供的引用内容,可以得知这是一道关于迷宫问题的题目,需要使用Java语言进行编写。具体来说,这道题目需要实现一个迷宫的搜索算法,找到从起点到终点的最短路径。可以使用广度优先搜索或者深度优先搜索算法来解决这个问题。 下面是一个使用广度优先搜索算法的Java代码示例: ```java import java.util.*; public class Main { static int[][] maze = new int[5][5]; // 迷宫地图 static int[][] dir = {{0, 1}, {0, -1}, {1, 0}, {-1, 0}}; // 方向数组 static boolean[][] vis = new boolean[5][5]; // 标记数组 static int[][] pre = new int[5][5]; // 记录路径 public static void main(String[] args) { Scanner sc = new Scanner(System.in); for (int i = 0; i < 5; i++) { for (int j = 0; j < 5; j++) { maze[i][j] = sc.nextInt(); } } bfs(0, 0); Stack<Integer> stack = new Stack<>(); int x = 4, y = 4; while (x != 0 || y != 0) { stack.push(x * 5 + y); int t = pre[x][y]; x = t / 5; y = t % 5; } stack.push(0); while (!stack.empty()) { System.out.print(stack.pop() + " "); } } static void bfs(int x, int y) { Queue<Integer> qx = new LinkedList<>(); Queue<Integer> qy = new LinkedList<>(); qx.offer(x); qy.offer(y); vis[x][y] = true; while (!qx.isEmpty()) { int tx = qx.poll(); int ty = qy.poll(); if (tx == 4 && ty == 4) { return; } for (int i = 0; i < 4; i++) { int nx = tx + dir[i][0]; int ny = ty + dir[i][1]; if (nx >= 0 && nx < 5 && ny >= 0 && ny < 5 && maze[nx][ny] == 0 && !vis[nx][ny]) { vis[nx][ny] = true; pre[nx][ny] = tx * 5 + ty; qx.offer(nx); qy.offer(ny); } } } } } ``` 该代码使用了广度优先搜索算法,首先读入迷宫地图,然后从起点开始进行搜索,直到找到终点为止。在搜索的过程中,使用标记数组记录已经访问过的位置,使用路径数组记录路径。最后,使用栈来输出路径。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值