D - Idiomatic Phrases Game(最短路径)

Tom is playing a game called Idiomatic Phrases Game. An idiom consists of several Chinese characters and has a certain meaning. This game will give Tom two idioms. He should build a list of idioms and the list starts and ends with the two given idioms. For every two adjacent idioms, the last Chinese character of the former idiom should be the same as the first character of the latter one. For each time, Tom has a dictionary that he must pick idioms from and each idiom in the dictionary has a value indicates how long Tom will take to find the next proper idiom in the final list. Now you are asked to write a program to compute the shortest time Tom will take by giving you the idiom dictionary.

Input
The input consists of several test cases. Each test case contains an idiom dictionary. The dictionary is started by an integer N (0 < N < 1000) in one line. The following is N lines. Each line contains an integer T (the time Tom will take to work out) and an idiom. One idiom consists of several Chinese characters (at least 3) and one Chinese character consists of four hex digit (i.e., 0 to 9 and A to F). Note that the first and last idioms in the dictionary are the source and target idioms in the game. The input ends up with a case that N = 0. Do not process this case.
Output
One line for each case. Output an integer indicating the shortest time Tome will take. If the list can not be built, please output -1.
Sample Input
5
5 12345978ABCD2341
5 23415608ACBD3412
7 34125678AEFD4123
15 23415673ACC34123
4 41235673FBCD2156
2
20 12345678ABCD
30 DCBF5432167D
0
Sample Output
17
-1


本题翻译: 没错我就是整整瞪了它20分钟 这题讲什么??老子看不懂

问了下同学  原来是 成语的开头是第一行的最后四个字  成语的结尾是最后一行的开头四个字 

问能不能有条路可以从第一个去最后一个 不能输出-1 能输出最短的路  

大体的意思就是这个

最重要的在于转换其中的关系 嗯就是说

if(i!=j)
   	    	{
   	    	   if(same(look[i].idiom,look[j].idiom)==1)
			   edge[i][j]=look[i].t;
   	    	}
这个是我认为蛮重要的处理 剩下的就是套模板了没有其他了  嗯就是这样子了

还有就是不能做死取名是is_same  到codeblock里看 发现是绿色的就知道自己哪里有问题了 

百度了一下还是不知道哈哈哈哈~~~~

源代码链接是:http://blog.csdn.net/juncoder/article/details/36262733

C++代码:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#define inf 0x3f3f3f3f
using namespace std;
int n;
struct node
{
	int t;
	char idiom[100];
}look[1005];
int edge[1005][1005],dis[1005],vis[1005];

int same(char *str1,char *str2)
{
	char s[10];
	int i;
	int ll=strlen(str1);
	int k=0;
	strncpy(s,str2,4);
	for(i=ll-4;i<ll;i++)
	{
		if(str1[i]!=s[k++])
		return 0;
	}
	return 1;
}
void dijkstra()
{
	int i,j,minn,u;
	for(i=1;i<=n;i++)
	{
	   dis[i]=edge[1][i];
	   vis[i]=0;
	}
	dis[1]=0;
	vis[1]=1;
	for(i=1;i<=n;i++)
	{
		minn=inf;
		for(j=1;j<=n;j++)
		{
			if(vis[j]==0&&dis[j]<minn)
			{
				minn=dis[j];
				u=j;
			}
		}
		vis[u]=1;
		for(j=1;j<=n;j++)
		{
			if(vis[j]==0&&dis[j]>dis[u]+edge[u][j])
		        dis[j]=dis[u]+edge[u][j];
		}
	}
	if(dis[n]!=inf)
    printf("%d\n",dis[n]);
	else
	printf("-1\n");
}
int main()
{
	   	int i,j;
   while(scanf("%d",&n)!=EOF)
   {
   	if(n==0)break;
   	for(i=1;i<=n;i++)
   	   for(j=1;j<=n;j++)
   	      if(i==j)
		  edge[i][j]=0;
   	      else
		  edge[i][j]=inf;
   	for(i=1;i<=n;i++)
   	scanf("%d%s",&look[i].t,look[i].idiom);

   	for(i=1;i<=n;i++)
   	    for(j=1;j<=n;j++)
   	    {
   	    	if(i!=j)
   	    	{
   	    	   if(same(look[i].idiom,look[j].idiom)==1)
			   edge[i][j]=look[i].t;
   	    	}
   	    }
	  dijkstra();
   }
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值