HDU 1546 Idiomatic Phrases Game

链接:

http://acm.hdu.edu.cn/showproblem.php?pid=1546


题目:

Idiomatic Phrases Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 969    Accepted Submission(s): 300


Problem Description
Tom is playing a game called Idiomatic Phrases Game. An idiom consists of several Chinese characters and has a certain meaning. This game will give Tom two idioms. He should build a list of idioms and the list starts and ends with the two given idioms. For every two adjacent idioms, the last Chinese character of the former idiom should be the same as the first character of the latter one. For each time, Tom has a dictionary that he must pick idioms from and each idiom in the dictionary has a value indicates how long Tom will take to find the next proper idiom in the final list. Now you are asked to write a program to compute the shortest time Tom will take by giving you the idiom dictionary. 
 

Input
The input consists of several test cases. Each test case contains an idiom dictionary. The dictionary is started by an integer N (0 < N < 1000) in one line. The following is N lines. Each line contains an integer T (the time Tom will take to work out) and an idiom. One idiom consists of several Chinese characters (at least 3) and one Chinese character consists of four hex digit (i.e., 0 to 9 and A to F). Note that the first and last idioms in the dictionary are the source and target idioms in the game. The input ends up with a case that N = 0. Do not process this case. 
 

Output
One line for each case. Output an integer indicating the shortest time Tome will take. If the list can not be built, please output -1.
 

Sample Input
  
  
5 5 12345978ABCD2341 5 23415608ACBD3412 7 34125678AEFD4123 15 23415673ACC34123 4 41235673FBCD2156 2 20 12345678ABCD 30 DCBF5432167D 0
 

Sample Output
  
  
17 -1
 


题目大意:

给出n个“成语”, 这写成语至少由3个“汉字”组成,所谓的“汉字”,是指4个连续的16进制数字(1~9, A~F)。 

以第一个成语作为起点,最后一个作为终点, 需要找出一个序列,这个序列的前一个成语的最后一个“汉字”与后一个成语的第一个“汉字”是相同的,求最少花费时间。


分析与总结:

建好图之后就是最基本的最短路问题。

在输入时,对于每个成语只需要保存第一个汉字与最后一个汉字即可。



代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#include<utility>
using namespace std;

typedef pair<int,int>pii;
priority_queue<pii,vector<pii>,greater<pii> >q;

const int INF = 0x7fffffff;
const int VN  = 1005;

struct Edge{int v,next,w;}E[VN*VN];
struct Idiom{
    char beg[5], end[5];
}arr[VN];

int n,size;
int head[VN];
int d[VN];
int cost[VN];

void init(){
    size=0;
    memset(head, -1, sizeof(head));
    while(!q.empty())q.pop();
}
void addEdge(int u,int v,int w){
    E[size].v=v, E[size].w=w;
    E[size].next = head[u];
    head[u] = size++;
}

void Dijkstra(int src){
    for(int i=1; i<=n; ++i) d[i] = INF;
    d[src] = 0;
    q.push(make_pair(d[src],src));
    while(!q.empty()){
        pii x = q.top(); q.pop();
        int u = x.second;
        if(d[u] != x.first) continue;
        for(int e=head[u]; e!=-1; e=E[e].next){
            int tmp = d[u] + E[e].w;
            if(d[E[e].v] > tmp){
                d[E[e].v] = tmp;
                q.push(make_pair(tmp, E[e].v));
            }
        }
    }
}

int main(){
    int w;
    char str[100];
    while(scanf("%d",&n)&&n){
        init();
        for(int i=1; i<=n; ++i){
            scanf("%d %s",&cost[i],str);
            for(int j=0; j<5; ++j) 
                arr[i].beg[j]=str[j];
            int len = strlen(str);
            for(int j=len-4,k=0; j<len; ++j,++k) 
                arr[i].end[k]=str[j];
            arr[i].end[4] = arr[i].beg[4] = 0;
        }
        for(int i=1; i<n; ++i){
            for(int j=1; j<=n; ++j){
                if(strcmp(arr[i].end, arr[j].beg)==0)
                    addEdge(i,j,cost[i]); 
            }
        }
        Dijkstra(1);
        if(d[n]!=INF) printf("%d\n", d[n]);
        else  puts("-1");
    }
    return 0;
}


 
 

——  生命的意义,在于赋予它意义。

          
     原创 http://blog.csdn.net/shuangde800 , By   D_Double  (转载请标明)

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值