Idiomatic Phrases Game

Tom is playing a game called Idiomatic Phrases Game. An idiom consists of several Chinese characters and has a certain meaning. This game will give Tom two idioms. He should build a list of idioms and the list starts and ends with the two given idioms. For every two adjacent idioms, the last Chinese character of the former idiom should be the same as the first character of the latter one. For each time, Tom has a dictionary that he must pick idioms from and each idiom in the dictionary has a value indicates how long Tom will take to find the next proper idiom in the final list. Now you are asked to write a program to compute the shortest time Tom will take by giving you the idiom dictionary.

Input
The input consists of several test cases. Each test case contains an idiom dictionary. The dictionary is started by an integer N (0 < N < 1000) in one line. The following is N lines. Each line contains an integer T (the time Tom will take to work out) and an idiom. One idiom consists of several Chinese characters (at least 3) and one Chinese character consists of four hex digit (i.e., 0 to 9 and A to F). Note that the first and last idioms in the dictionary are the source and target idioms in the game. The input ends up with a case that N = 0. Do not process this case.
Output
One line for each case. Output an integer indicating the shortest time Tome will take. If the list can not be built, please output -1.
Sample Input
5
5 12345978ABCD2341
5 23415608ACBD3412
7 34125678AEFD4123
15 23415673ACC34123
4 41235673FBCD2156
2
20 12345678ABCD
30 DCBF5432167D
0
Sample Output
17
-1
这个题难点还是在边的创建,给我们一堆点,问我们最短的路径,然后我们没有什么好办法,只能两个for循环,然后符合条件的创建边。
#include<stdio.h>
#include<string.h>
#define INF 0x3f3f3f3f
using namespace std;

int n;
struct//每个点的权值,和字符
{
    int w;
    char str[100];
}node[1000];
int mp[1000][1000];
int dis[1000];
int vis[1000];

void dijkstra()
{
    memset(vis,0,sizeof(vis));
    memset(dis,INF,sizeof(dis));
    dis[0]=0;
    for(int i=0;i<=n;i++)
    {
        int temp=INF;int m;
        for(int j=0;j<=n;j++)
        {
            if(!vis[j]&&dis[j]<temp)
            {
                temp=dis[j];
                m=j;
            }
        }
        vis[m]=1;
        for(int j=0;j<=n;j++)
        {
            if(dis[j]>dis[m]+mp[m][j])
                dis[j]=dis[m]+mp[m][j];
        }
    }
}


int main()
{
    while(~scanf("%d",&n)&&n)
    {
        memset(mp,INF,sizeof(mp));
        for(int i=0;i<n;i++)
        {
            scanf("%d %s",&node[i].w,node[i].str);
        }
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<n;j++)
            {
                if(i!=j)
                {
                    int len=strlen(node[i].str);
                    if(node[i].str[len-4]==node[j].str[0]&&node[i].str[len-3]==node[j].str[1]&&node[i].str[len-2]==node[j].str[2]&&node[i].str[len-1]==node[j].str[3])
                        mp[i][j]=node[i].w;//标定u,v,w
                }
            }
        }
        dijkstra();
        if(dis[n-1]==INF)
            printf("-1\n");
        else
            printf("%d\n",dis[n-1]);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值