E - Longest Ordered Subsequence(动态规划)最长升成子序列问题

   
   

E - Longest Ordered Subsequence

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence ( a1, a2, ..., aN) be any sequence ( ai1, ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8). Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.
Input
The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000
Output
Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.
Sample Input
7
1 7 3 5 9 4 8
Sample Output
4



嗯就是最长升成子序列的问题 然后就是 主要的关键点在于要利用二分啊 心痛没学扎实没好意思说 

 代码: 
 
#include<cstdio>
#include<cstring>
#define MAXN 1005
int arr[MAXN],ans[MAXN],len;
int search(int k)
{
	int left=0;
	int right=len;
	while(left<right)
	{
		int mid=(left+right)/2;
		if(ans[mid]>=arr[k]) right=mid;
		else left=mid+1;
	}
	return left;
}//这个东西求得是最小(是最小哦 这样子才能替换)比它大的数的位置 嗯我觉得这一点理解很重要 
int main()
{
	int n;
	scanf("%d",&n);
	for(int i=1;i<=n;i++)
	scanf("%d",&arr[i]);
	len=1;
	ans[1]=arr[1];
	for(int i=2;i<=n;i++)
	{
		if(arr[i]>ans[len])
			ans[++len]=arr[i];
		else
		{
			int pos=search(i);
			ans[pos]=arr[i];
		}
	}
	printf("%d\n",len);	
	return 0;
}
然后还有就是要注意的就是比如 2
2 5 7 3 虽然输出的长度是3  但是其实吧   排在ans里面的东西是2 3 7   嗯 把5给替换了就是这个样子

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值