F - Substrings(一些函数的运用)


 F - Substrings(一些函数的运用)

You are given a number of case-sensitive strings of alphabetic characters, find the largest string X, such that either X, or its inverse can be found as a substring of any of the given strings.

Input
The first line of the input file contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case contains a single integer n (1 <= n <= 100), the number of given strings, followed by n lines, each representing one string of minimum length 1 and maximum length 100. There is no extra white space before and after a string.
Output
There should be one line per test case containing the length of the largest string found.
Sample Input
2
3
ABCD
BCDFF
BRCD
2
rose
orchid
Sample Output
2
2

求最长公共子串,嗯反的正的是都可以

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#include<cmath>
using namespace std;
char str[105][105];
int len[105];
char s1[105],s2[105];
int main()
{
    int t,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        int minn=1000,u=-1;
        for(int i=0;i<n;i++)
        {
            scanf("%s",str[i]);
            len[i]=strlen(str[i]);
            if(len[i]<minn)
                minn=len[i],u=i; //找到最小的字符串了并且知道他们大家的字符串长度了  因为最小的字符串可能有多个 但是相等没有关系!
                                 //因为最后都是决定于最小的 记录下最短字符串在哪个地方
        }
        int maxn=0,k,i,j,gg,length;
        for(i=0;i<minn;i++)
        {
            for(j=1;j<=minn-i;j++)
            {
                strncpy(s1,str[u]+i,j);//正向字符串从s1中copy   j个
                s1[j]='\0';
                strcpy(s2,s1);
                length=strlen(s1);//反向字符串
                strrev(s2);//这个是字符串反转函数也可以下面注释掉的那样子的求法
                /*  for(k=length-1,gg=0;k>=0;k--,gg++)
                s2[k]=s1[gg];
                s2[length]='\0';*/
               int flag=1;
               for(k=0;k<n;k++)
               {
                    if(!strstr(str[k],s1)&&!strstr(str[k],s2))//这个函数是比较后面是否在前面出现 在返回地址
                    {

                        flag=0;
                        break;
                    }
               }
               if(flag)
                   maxn=max(maxn,length);
            }
        }
        printf("%d\n",maxn);
    }
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值