Number Sequence

Number Sequence

Describe

A single positive integer i is given. Write a program to find the digit located in the position i in the sequence of number groups S1S2…Sk. Each group Sk consists of a sequence of positive integer numbers ranging from 1 to k, written one after another.
For example, the first 80 digits of the sequence are as follows:
11212312341234512345612345671234567812345678912345678910123456789101112345678910

Input
The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by one line for each test case. The line for a test case contains the single integer i (1 ≤ i ≤ 2147483647)

Output
There should be one output line per test case containing the digit located in the position i.

Sample Input

2
8
3

Sample Output

2
2

注意,是求第i位的数字而不是数,例如12345678910这个序列中第10位数字是1而不是10。我们可以将整个序列分成一个个以数1开始的小序列,利用cmath中的log10函数可以计算出一个数的位数,用数组存放小序列的位数,从而确定第i位所在小序列,进而确定它在哪一个数的哪一位上,最后输出即可。

#include<iostream>
#include<cmath>
#define N 32000

using namespace std;

//小心溢出
unsigned int a[N]={0,1};
unsigned int b[N]={0,1};

int main()
{
    for(int i=2;i<N;i++)
    {
        a[i]=a[i-1]+log10((double)i)+1;//log10(n)+1即n的位数
        b[i]=b[i-1]+a[i];
    }
    int t;
    cin>>t;
    while(t--)
    {
        int i,j,n,sum=0;
        cin>>n;
        for(i=1;i<N;i++)//定位所在序列
        {
            if(b[i]>=n)
                break;
        }
        n-=b[i-1];
        for(j=1;j<N;j++)//定位所在数
        {
            sum+=log10((double)j)+1;
            if(sum>=n)
                break;
        }
        n=sum-n;
        while(n--) j/=10;//将所求数位置于个位
        cout<<j%10<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值