You Are the One (区间dp)

You Are the One

  The TV shows such as You Are the One has been very popular. In order to meet the need of boys who are still single, TJUT hold the show itself. The show is hold in the Small hall, so it attract a lot of boys and girls. Now there are n boys enrolling in. At the beginning, the n boys stand in a row and go to the stage one by one. However, the director suddenly knows that very boy has a value of diaosi D, if the boy is k-th one go to the stage, the unhappiness of him will be (k-1)*D, because he has to wait for (k-1) people. Luckily, there is a dark room in the Small hall, so the director can put the boy into the dark room temporarily and let the boys behind his go to stage before him. For the dark room is very narrow, the boy who first get into dark room has to leave last. The director wants to change the order of boys by the dark room, so the summary of unhappiness will be least. Can you help him?

Input   The first line contains a single integer T, the number of test cases.  For each case, the first line is n (0 < n <= 100)
  The next n line are n integer D1-Dn means the value of diaosi of boys (0 <= Di <= 100)
Output   For each test case, output the least summary of unhappiness .
Sample Input
2
  
5
1
2
3
4
5

5
5
4
3
2
2
Sample Output
Case #1: 20
Case #2: 24

题目大意转载:

题目大意就是说给定一个有序序列和一个栈,对于队伍前头的一个人,有两个操作,一个是直接迈向舞台,另一个操作就是迈入栈中。在一个时间下,迈向舞台的人可以是原始队伍里的人,也可以是栈里面的人。举例来说,假定队伍此时为 队首=>4 5<=队尾,栈此时为 栈顶=>3 2 1 <=栈底,那么下一个时刻可能是4进入栈中,或者4进入舞台,或者3从栈中去向舞台。

代码

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
const int inf=0x3f3f3f3f;
int d[110],dp[110][110],sum[110];
int main()
{
    int t,n,cnt=1;
    scanf("%d",&t);
    while(t--)
    {
        sum[0]=0;
        scanf("%d",&n);
        for(int i=1; i<=n; ++i)
        {
            scanf("%d",&d[i]);
            sum[i]=sum[i-1]+d[i];
        }
        memset(dp,0,sizeof(dp));
        for(int len=1; len<=n; ++len)//区间长度
        {
            for(int i=1; i+len-1<=n; ++i)//起点
            {
                int j=i+len-1;//终点
                dp[i][j]=inf;
                for(int k=1;k<=len;k++)//表示第k个上场的因为区间长度是len个所以说就从1到len表示说它的
                //出场顺序,然后因为这个东西已经出现了还要分成两部分一部分就是 k之前一部分是k之后到len的
                //还有就是这个家伙出场所以有愤怒值就是 k-1  * anger[i] 而且到此刻k为止后面的人都等了那么就了也要加上去
                dp[i][j]=min(dp[i][j],dp[i+1][i+k-1]+dp[i+k][j]+(k-1)*d[i]+k*(sum[j]-sum[i+k-1]));
            }
        }
        printf("Case #%d: %d\n",cnt++,dp[1][n]);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值