You Are the One(区间dp)

Description

The TV shows such as You Are the One has been very popular. In order to meet the need of boys who are still single, TJUT hold the show itself. The show is hold in the Small hall, so it attract a lot of boys and girls. Now there are n boys enrolling in. At the beginning, the n boys stand in a row and go to the stage one by one. However, the director suddenly knows that very boy has a value of diaosi D, if the boy is k-th one go to the stage, the unhappiness of him will be (k-1)*D, because he has to wait for (k-1) people.
Luckily, there is a dark room in the Small hall, so the director can put the boy into the dark room temporarily and let the boys behind his go to stage before him. For the dark room is very narrow, the boy who first get into dark room has to leave last. The director wants to change the order of boys by the dark room, so the summary of unhappiness will be least. Can you help him?

Input

The first line contains a single integer T, the number of test cases. For each case, the first line is n (0 < n <= 100)
The next n line are n integer D1-Dn means the value of diaosi of boys (0 <= Di <= 100)

Output

For each test case, output the least summary of unhappiness .

Sample Input

2
  
5
1
2
3
4
5

5
5
4
3
2
2

Sample Output

Case #1: 20
Case #2: 24


题意:

N N 个男生,每个男生都有对应的一个值D,如果这个男生第k个出场,那么不高兴程度为(k-1)*D,现在可以通过某个操作改变次序(详见题面加粗部分),问最小的不高兴程度?


分析:

对于 i,i+1,i+2,...,i+k1,i+k,..,j i , i + 1 , i + 2 , . . . , i + k − 1 , i + k , . . , j 这段序列,将 i i 放入小黑屋,在i+k1上场后再出来,则序列变为 i+1,i+2,...,i+k1,i,i+k,...,j i + 1 , i + 2 , . . . , i + k − 1 , i , i + k , . . . , j ,即, i i 为当前区间第 k 个上场的人,则当前区间的不开心度为

dp(i+1,i+k1)+vik+vi+k(k+1)+vi+k+1(k+2)++vj(ji+1) d p ( i + 1 , i + k − 1 ) + v i ∗ k + v i + k ∗ ( k + 1 ) + v i + k + 1 ∗ ( k + 2 ) + … + v j ∗ ( j − i + 1 )

dp(i+1,i+k1)+vik+k(sumjsumi+k1)+dp(i+k,j) d p ( i + 1 , i + k − 1 ) + v i ∗ k + k ∗ ( s u m j − s u m i + k − 1 ) + d p ( i + k , j )

其中 sum s u m 为前缀和


代码:
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h>
#include<algorithm>
#include<time.h>
#include<iostream>
#include<vector>
#include<stack>
#include<queue>
#include<set>
#include<map>

using namespace std;

#define bll long long

const int maxn = 110;
const int inf = 1e9+100;
int T,n;
int f[maxn][maxn],v[maxn],sum[maxn];

int dp(int i,int j)
{
    if (i >= j) return 0;
    if (f[i][j] != inf) return f[i][j];
    for (int k=1;k<=j-i+1;k++)
        f[i][j] = min(f[i][j],dp(i+1,i+k-1)+dp(i+k,j)+k*(sum[j]-sum[i+k-1])+v[i]*(k-1));
    return f[i][j];
}

int main()
{
    scanf("%d",&T);
    for (int Case = 1; Case <= T; Case++)
    {
        scanf("%d",&n);
        for (int i=1;i<=n;i++) 
        {
            scanf("%d",&v[i]);
            sum[i] = sum[i-1]+v[i];
        }
        for (int i=1;i<=n;i++)
            for (int j=1;j<=n;j++) 
                f[i][j] = inf;
        printf("Case #%d: %d\n",Case,dp(1,n));
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值