POJ - 3984 迷宫问题

定义一个二维数组:

int maze[5][5] = {

0, 1, 0, 0, 0,

0, 1, 0, 1, 0,

0, 0, 0, 0, 0,

0, 1, 1, 1, 0,

0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
Input
一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
Output
左上角到右下角的最短路径,格式如样例所示。
Sample Input
0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
Sample Output
(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

思路:就是简单的写出路径的题,如果用BFS(广搜)我的方法是在结构体里定义一个地图,先复制地图,再把每次走过的路都放在新地图中。如果是DFS(深搜)(这中写出路径的题一般都是用深搜的方法),和广搜一样是定义一个地图,先复制地图,再把每次走过的路都存进新地图中,具体看代码。

DFS(深搜)

#include <stdio.h>
#include <stdlib.h>
#include <algorithm>
#include <string.h>
#include <iostream>
#include <vector>
using namespace std;
typedef struct
{
  int x,y;
}weizhi;
int a[5][5],b[5][5],ans=1000,dis[4][2]={{1,0},{-1,0},{0,1},{0,-1}},arr[5][5];
void dfs(int c,int d,int step)
{
    weizhi nc,nd;
    nc.x=c,nc.y=d;
    if(c==4&&d==4)
    {
        if(ans>step)
        {for(int h=0;h<5;h++)
        {
            for(int t=0;t<5;t++)
            {
                arr[h][t]=b[h][t];//复制地图
            }
        }}
        return;
    }
    for(int i=0;i<4;i++)
    {
        nd.x=nc.x+dis[i][0];
        nd.y=nc.y+dis[i][1];
        if(nd.x>=0&&nd.x<5&&nd.y>=0&&nd.y<5&&a[nd.x][nd.y]==0&&b[nd.x][nd.y]==0)
        {
            b[nd.x][nd.y]=1;
            dfs(nd.x,nd.y,step+1);
            b[nd.x][nd.y]=0;//回溯标记
        }
    }
}
int main()
{
    for(int i=0;i<5;i++)
    {
        for(int j=0;j<5;j++)
        {
            cin>>a[i][j];
        }
    }
    dfs(0,0,0);
    printf("(0, 0)\n");
    for(int i=0;i<5;i++)
    {
        for(int j=0;j<5;j++)
        {
            if(arr[i][j]==1)
                printf("(%d, %d)\n",i,j);
        }
    }
}

BFS(广搜)

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <string>
#include <cstring>
#include <cstdlib>
#include <math.h>
#include <stack>
#include <queue>
#include <string.h>
using namespace std;
typedef struct
{
    int x,y,z;
    int arr[10][10];//定义地图
}weizhi;
int main()
{
    int a[10][10],i,j,dis[4][2]={{1,0},{-1,0},{0,1},{0,-1}};
    for(i=0;i<5;i++)
    {
        for(j=0;j<5;j++)
        {
            cin>>a[i][j];
        }
    }
    queue<weizhi>s;
    weizhi start;
    start.x=0,start.y=0;
    memset(start.arr,0,sizeof(start.arr));
    start.arr[start.x][start.y]=6;
    s.push(start);
    while(s.size())
    {
        weizhi b=s.front(),d;
        memset(d.arr,0,sizeof(d.arr));
        s.pop();
        if(b.x==4&&b.y==4)
        {
            for(i=0;i<5;i++)
            {
                for(j=0;j<5;j++)
                {
                    if(b.arr[i][j]==6)
                    {
                        printf("(%d, %d)\n",i,j);
                    }
                }
            }
            break;
        }
        for(i=0;i<4;i++)
        {
            d.x=b.x+dis[i][0];
            d.y=b.y+dis[i][1];
            if(d.x>=0&&d.x<5&&d.y>=0&&d.y<5&&a[d.x][d.y]==0)
            {
                a[b.x][b.y]=1;
                for(int k=0;k<5;k++)
                {
                    for(int t=0;t<5;t++)
                    {
                        d.arr[k][t]=b.arr[k][t];
                    }
                }
                d.arr[d.x][d.y]=6;//先复制地图,再把走过的点存入新数组
                s.push(d);
            }
        }
    }
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
根据提供的引用内容,可以得知这是一道关于迷宫问题的题目,需要使用Java语言进行编写。具体来说,这道题目需要实现一个迷宫的搜索算法,找到从起点到终点的最短径。可以使用广度优先搜索或者深度优先搜索算法来解决这个问题。 下面是一个使用广度优先搜索算法的Java代码示例: ```java import java.util.*; public class Main { static int[][] maze = new int[5][5]; // 迷宫地图 static int[][] dir = {{0, 1}, {0, -1}, {1, 0}, {-1, 0}}; // 方向数组 static boolean[][] vis = new boolean[5][5]; // 标记数组 static int[][] pre = new int[5][5]; // 记录径 public static void main(String[] args) { Scanner sc = new Scanner(System.in); for (int i = 0; i < 5; i++) { for (int j = 0; j < 5; j++) { maze[i][j] = sc.nextInt(); } } bfs(0, 0); Stack<Integer> stack = new Stack<>(); int x = 4, y = 4; while (x != 0 || y != 0) { stack.push(x * 5 + y); int t = pre[x][y]; x = t / 5; y = t % 5; } stack.push(0); while (!stack.empty()) { System.out.print(stack.pop() + " "); } } static void bfs(int x, int y) { Queue<Integer> qx = new LinkedList<>(); Queue<Integer> qy = new LinkedList<>(); qx.offer(x); qy.offer(y); vis[x][y] = true; while (!qx.isEmpty()) { int tx = qx.poll(); int ty = qy.poll(); if (tx == 4 && ty == 4) { return; } for (int i = 0; i < 4; i++) { int nx = tx + dir[i][0]; int ny = ty + dir[i][1]; if (nx >= 0 && nx < 5 && ny >= 0 && ny < 5 && maze[nx][ny] == 0 && !vis[nx][ny]) { vis[nx][ny] = true; pre[nx][ny] = tx * 5 + ty; qx.offer(nx); qy.offer(ny); } } } } } ``` 该代码使用了广度优先搜索算法,首先读入迷宫地图,然后从起点开始进行搜索,直到找到终点为止。在搜索的过程中,使用标记数组记录已经访问过的位置,使用径数组记录径。最后,使用栈来输出径。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值