1143. Lowest Common Ancestor (30)

1143. Lowest Common Ancestor (30)

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

A binary search tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

Given any two nodes in a BST, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the BST, respectively. In the second line, N distinct integers are given as the preorder traversal sequence of the BST. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the BST, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found..

Sample Input:

6 8
6 3 1 2 5 4 8 7
2 5
8 7
1 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 5 is 3.
8 is an ancestor of 7.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

 

转载来自:https://www.liuchuo.net/archives/4616   Orz

代码: 取巧

#include<bits/stdc++.h>
using namespace std;
map<int, bool> mp;
int main() {
    int m, n, u, v, a;
    scanf("%d %d", &m, &n);
    vector<int> pre(n);
    for (int i = 0; i < n; i++) {
        scanf("%d", &pre[i]);
        mp[pre[i]] = true;
    }
    for (int i = 0; i < m; i++) {
        scanf("%d %d", &u, &v);
        for(int j = 0; j < n; j++) {
            a = pre[j];
            if ((a > u && a < v)|| (a > v && a < u) || (a == u) || (a == v))
				break;
        } 
        /*
		这个地方是真的写得很棒了.....  
		(a > u && a < v)|| (a > v && a < u) 求他们的父亲节点 
		Orz 自己从没有这么考虑过  我的答案错误应该也是错的这里 
		*/ 
        if (mp[u] == false && mp[v] == false)
            printf("ERROR: %d and %d are not found.\n", u, v);
        else if (mp[u] == false || mp[v] == false)
            printf("ERROR: %d is not found.\n", mp[u] == false ? u : v);
        else if (a == u || a == v)
            printf("%d is an ancestor of %d.\n", a, a == u ? v : u);
        else
            printf("LCA of %d and %d is %d.\n", u, v, a);
    }
    return 0;
}

代码:数据结构

这代码是转载的 代码过不了 有两个测试点T了 不过我很喜欢他的代码风格觉得很棒 就转了

转载来自:https://blog.csdn.net/mapoos/article/details/79618675

#include <cstdio>
#include <vector>
#include <cstring>
#include <map>
using namespace std;

map<int, bool> hashTable;       // 标记树中元素

struct node
{
    int data;
    node *lchild, *rchild;
};

/* 新建结点 */
node* newNode(int x)
{
    node* root = new node;
    root->data = x;
    root->lchild = root->rchild = NULL;
    return root;
}

/* 插入结点 */
void insertBST(node* &root, int x)
{
    if (root == NULL)
    {
        root = newNode(x);
        return;
    }

    if (x < root->data)
        insertBST(root->lchild, x);
    else
        insertBST(root->rchild, x);
}

/* 创建BST */
node* createBST(vector<int> pre)
{
    node* root = NULL;
    for (int i = 0; i < pre.size(); i++)
        insertBST(root, pre[i]);
    return root;
}

/* 查找公共祖先 */
int findRoot(node* root, int a, int b)
{
    // a,b结点在根结点左右两侧,说明该根结点就是公共祖先
    if (a < root->data && b > root->data || a > root->data && b < root->data)
        return root->data;

    // a(b)即是b(a)的祖先
    if (root->data == a || root->data == b)
        return root->data;

    // 继续向左右子树查找
    if (a < root->data && b < root->data)
        return findRoot(root->lchild, a, b);
    else if (a > root->data && b > root->data)
        return findRoot(root->rchild, a, b);
}

int main()
{
    int m, n, a, b;
    vector<int> pre;

    scanf("%d %d", &m, &n);
    for (int i = 0; i < n; i++)
    {
        int x;
        scanf("%d", &x);
        hashTable[x] = true;        // 标记树中结点
        pre.push_back(x);
    }

    node* root = createBST(pre);    // 创建BST

    for (int i = 0; i < m; i++)
    {
        scanf("%d %d", &a, &b);

        bool findA = hashTable[a];
        bool findB = hashTable[b];

        // a,b不在树中的情况
        if (!findA && !findB)
        {
            printf("ERROR: %d and %d are not found.\n", a, b);
            continue;
        }
        else if (!findA)
        {
            printf("ERROR: %d is not found.\n", a);
            continue;
        }
        else if (!findB)
        {
            printf("ERROR: %d is not found.\n", b);
            continue;
        }

        // a,b都在树中的前提下,查找公共祖先
        int ans = findRoot(root, a, b);
        if (ans == a)
            printf("%d is an ancestor of %d.\n", a, b);
        else if (ans == b)
            printf("%d is an ancestor of %d.\n", b, a);
        else
            printf("LCA of %d and %d is %d.\n", a, b, ans);
    }

    return 0;
}

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值