LCA in a Binary Tree

给出一棵树,求两个节点的最近公共祖先。

每次让两个点中深度大的点向上跳,直到两个点相交。很明显,当数据是一条链时,每次询问的时间复杂度可达到O(n)。

对于此题是采用的lca算法。

对于一棵普通的二叉树

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

Given any two nodes in a binary tree, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the binary tree, respectively. In each of the following two lines, N distinct integers are given as the inorder and preorder traversal sequences of the binary tree, respectively. It is guaranteed that the binary tree can be uniquely determined by the input sequences. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the binary tree, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found..

Sample Input:

6 8
7 2 3 4 6 5 1 8
5 3 7 2 6 4 8 1
2 6
8 1
7 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 6 is 3.
8 is an ancestor of 1.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

分析:不用建树~已知某个树的根结点,若a和b在根结点的左边,则a和b的最近公共祖先在当前子树根结点的左子树寻找,如果a和b在当前子树根结点的两边,则当前子树的根结点就是a和b的最近公共祖先,如果a和b在当前子树根结点的右边,则a和b的最近公共祖先就在当前子树的右子树寻找。中序加先序可以唯一确定一棵树,在不构建树的情况下,在每一层的递归中,可以得到树的根结点,在此时并入lca算法可以确定两个结点的公共祖先~

#include <bits/stdc++.h>
using namespace std;
map<int,int>pos;
vector<int>pre,in;
void lca(int inL,int inR,int rootPre,int a,int b){
    if(inL>inR) return;
    int rootIn=pos[pre[rootPre]],aIn=pos[a],bIn=pos[b];
    if(aIn<rootIn&&bIn<rootIn)
        lca(inL,rootIn-1,rootPre+1,a,b);
    else if(aIn>rootIn&&bIn>rootIn)
        lca(rootIn+1,inR,rootPre+rootIn-inL+1,a,b);
    else if((aIn<rootIn&&bIn>rootIn)||(aIn>rootIn&&bIn<rootIn))
        printf("LCA of %d and %d is %d.\n",a,b,in[rootIn]);
    else if(aIn==rootIn)
        printf("%d is an ancestor of %d.\n",a,b);
    else printf("%d is an ancestor of %d.\n",b,a);
}
int main(){
    int m,n;
    scanf("%d%d",&m,&n);
    pre.resize(n+1),in.resize(n+1);
    for(int i=1;i<=n;i++){
        scanf("%d",&in[i]);
        pos[in[i]]=i;
    }
    for(int i=1;i<=n;i++){
        scanf("%d",&pre[i]);
    }
    while(m--){
        int a,b;
        scanf("%d%d",&a,&b);
        if(pos[a]==0&&pos[b]==0)
            printf("ERROR: %d and %d are not found.\n",a,b);
        else if(pos[a]==0)
            printf("ERROR: %d is not found.\n",a);
        else if(pos[b]==0)
            printf("ERROR: %d is not found.\n",b);
        else lca(1,n,1,a,b);
    }
    return 0;
}

对于一棵二叉搜索树

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

A binary search tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

Given any two nodes in a BST, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the BST, respectively. In the second line, N distinct integers are given as the preorder traversal sequence of the BST. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the BST, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found..

Sample Input:

6 8
6 3 1 2 5 4 8 7
2 5
8 7
1 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 5 is 3.
8 is an ancestor of 7.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.
#include <iostream>
#include <vector>
#include <map>
using namespace std;
map<int,bool>mp;
int main(){
    int m,n,u,v,a;
    scanf("%d%d",&m,&n);
    vector<int>pre(n);
    for(int i=0;i<n;i++){
        scanf("%d",&pre[i]);
        mp[pre[i]]=true;
    }
    for(int i=0;i<m;i++){
        scanf("%d%d",&u,&v);
        for(int j=0;j<n;j++){
            a=pre[j];
            if((a>=u&&a<=v)||(a>=v&&a<=u)) break;
        }
        if(mp[u]==false&&mp[v]==false)
            printf("ERROR: %d and %d are not found.\n",u,v);
        else if(mp[u]==false||mp[v]==false)
            printf("ERROR: %d is not found.\n",mp[u]==false?u:v);
        else if(a==u||a==v)
            printf("%d is an ancestor of %d.\n",a,a==u?v:u);
        else printf("LCA of %d and %d is %d.\n",u,v,a);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值