1147 Heaps (30 分)

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree's postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:

3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56

Sample Output:

Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10

 题目大意:给定n个层序序列让你判断这些序列是大顶堆还是小顶堆,然后输出其后序遍历序列。 

分析:数据下表从0开始,堆是完全二叉树其下满足如下特性,设当前点是a[i],若孩子结点存在,则其左孩子为a[2*i+1],右孩子为a[2*i+2];若当前点为a[i],则其双亲结点为a[(i-1)/2]。对于大顶堆,任意非根结点满足a[i]<=a[(i-1)/2],对于小顶堆,任意非根结点满足a[i]>=a[(i-1)/2],有一个节点不满足条件则不是堆。至于后序遍历序列,知道了各结点的联系后,设当前点下标root,则左孩子root*2+1,右孩子root*2+2,然后进行后序遍历输出序列

代码如下:

#include <bits/stdc++.h>
using namespace std;
int m,n,a[1010];
bool ismax(int a[])
{
    for(int i=n-1;i>0;i--)
        if(a[i]>a[(i-1)/2])
            return false;
    return true;
}
bool ismin(int a[])
{
    for (int i=n-1;i>0;i--)
        if (a[i]<a[(i-1)/2])
            return false;
        return true;
}
void last (int root,bool& flag)
{
    if (root<n)
    {
        int lchild =root*2+1,rchild=2*root+2;
        last(lchild,flag);
        last(rchild,flag);
        printf("%s%d",flag?" ":"",a[root]);
        flag=true;
    }
}
int main() {
    cin>>m>>n;
    for (int i=0;i<m;i++)
    {
        for(int j=0;j<n;j++)
            cin>>a[j];
            bool flag=false;
            if (ismax(a))  cout<<"Max Heap"<<endl;
            else if (ismin(a)) cout<<"Min Heap"<<endl;
            else  cout<<"Not Heap"<<endl;
            last(0,flag);
            printf("\n");
    }
          return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值