1086 Tree Traversals Again(25 分)

1086 Tree Traversals Again(25 分)

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1

题目好了理解了好一会看着样例才知道意思

push进去的东西是先序
而pop出来的东西是中序
以此建立一颗树然后输出后序排序

hhhh姐姐我再也不怕先序中序建树和后序中序建树了so easy

代码:

#include<bits/stdc++.h>
using namespace std;
vector<int>post,pre,in;
int n,x;
struct node
{
	int data;
	node *left,*right;
};
void postOrder(node * root)
{
	if(root)
	{
		postOrder(root->left);
		postOrder(root->right);
		post.push_back(root->data);
	}
	return ;
}  
node* buildTree(vector<int>pre,vector<int>in, int pl, int pr,int il,int ir)
{
	if(pl > pr || il > ir) 
		return NULL;
	int pos;
	for(int i =il; i <= ir; i++)
	{
		if(pre[pl] == in[i])
		{
			pos = i;
			break; 
		} 
	}
	node * root= new node();
	root->data = pre[pl];
	root->left = root->right = NULL; 
	root->left = buildTree(pre,in,pl+1,pl+pos-il,il,pos-1);
	root->right = buildTree(pre,in,pl+pos-il+1,pr,pos+1,ir);
	return root;
}
int main()
{
	stack<int>st;
	scanf("%d",&n);
	char str[10];
	pre.push_back(-1);
	in.push_back(-1); 
	for(int i = 1; i <= n*2; i++ )
	{
		scanf("%s",str);
		if(strcmp(str,"Push") == 0)
		{
			scanf("%d",&x);
			st.push(x);
			pre.push_back(x);
		}else 
		{
			x = st.top();
			st.pop();
			in.push_back(x);
		}
	}
	node *root;
	root = buildTree(pre,in,1,n,1,n);
	postOrder(root);
	for(int i = 0 ; i< n; i++)
		printf("%d%c",post[i]," \n"[i==n-1]);
	return 0;
} 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值