An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.
Figure 1
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.
Output Specification:
For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input:
6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop
Sample Output:
3 4 2 6 5 1
C++:
/*
@Date : 2018-02-16 18:46:20
@Author : 酸饺子 (changzheng300@foxmail.com)
@Link : https://github.com/SourDumplings
@Version : $Id$
*/
/*
https://www.patest.cn/contests/pat-a-practise/1086
push序列就是个先序遍历
*/
#include <iostream>
#include <cstdio>
#include <vector>
#include <stack>
#include <memory>
using namespace std;
struct TNode
{
int data;
shared_ptr<TNode> left = nullptr, right = nullptr;
TNode(int d): data(d) {}
};
shared_ptr<TNode> build_tree(shared_ptr<TNode> &T, const vector<int> &pushSeq,
int ps, int pe, const vector<int> &in, int ins, int ine)
{
if (pe == ps)
return nullptr;
int root = pushSeq[ps];
T = make_shared<TNode>(root);
int inle;
for (int i = ins; i != ine; ++i)
{
if (in[i] == root)
{
inle = i;
break;
}
}
int ll = inle - ins;
T->left = build_tree(T->left, pushSeq, ps+1, ps+1+ll, in, ins, inle);
T->right = build_tree(T->right, pushSeq, ps+1+ll, pe, in, inle+1, ine);
return T;
}
static int output = 0;
void post_traversal(const shared_ptr<TNode> &T)
{
if (T != nullptr)
{
post_traversal(T->left);
post_traversal(T->right);
if (output++)
putchar(' ');
printf("%d", T->data);
}
return;
}
int main(int argc, char const *argv[])
{
int N;
scanf("%d", &N);
char order[10];
int num;
vector<int> pushSeq;
stack<int> S;
vector<int> in;
for (int i = 0; i != 2 * N; ++i)
{
scanf("%s", order);
if (order[1] == 'u')
{
scanf("%d", &num);
S.push(num);
pushSeq.push_back(num);
}
else if (order[1] == 'o')
{
in.push_back(S.top());
S.pop();
}
}
shared_ptr<TNode> T;
T = build_tree(T, pushSeq, 0, N, in, 0, N);
post_traversal(T);
putchar('\n');
return 0;
}