1004 Counting Leaves(30 分)
A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.
Input Specification:
Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:
ID K ID[1] ID[2] ... ID[K]
where ID
is a two-digit number representing a given non-leaf node, K
is the number of its children, followed by a sequence of two-digit ID
's of its children. For the sake of simplicity, let us fix the root ID to be 01
.
The input ends with N being 0. That case must NOT be processed.
Output Specification:
For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.
The sample case represents a tree with only 2 nodes, where 01
is the root and 02
is its only child. Hence on the root 01
level, there is 0
leaf node; and on the next level, there is 1
leaf node. Then we should output 0 1
in a line.
Sample Input:
2 1
01 1 02
Sample Output:
0 1
题目意思:
ght跟我说的,看不懂,然后 n,m表示一个有多少个节点,还有m个非叶子节点
然后接下来是m行 每一行都表示这个节点是什么东西,然后有多少个节点
最后输出要求输出每一层的叶子节点个数
代码:
#include<bits/stdc++.h>
using namespace std;
vector<int>vec[105],vc;
set<int>st;
int num[105],cnt = 0,maxn = 1;
void DFS(int x,int floor)
{
if(vec[x].size()==0)
{
vc.push_back(x);
num[floor]++;
return ;
}
for(int j = 0 ; j < vec[x].size(); j++)
{
floor++;
maxn = max(maxn,floor);
DFS(vec[x][j],floor);
floor--;
}
return;
}
int main()
{
int n,m;
scanf("%d%d",&n,&m);
for(int i = 1; i <= m; i++)
{
int x,k,y;
scanf("%d %d",&x,&k);
for(int j = 1; j <= k; j++)
{
scanf("%d",&y);
{
vec[x].push_back(y);
st.insert(y);
}
}
}
int root;
for(int i =1 ; i <= n; i++)
{
if(st.count(i) == 0)
{
root = i;
break;
}
}
DFS(root,1);
for(int i =1; i <= maxn; i++)
{
printf("%d%c",num[i]," \n"[i==maxn]);
}
return 0;
}