1004 Counting Leaves (30 分)

1004 Counting Leaves (30 分)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1

无语了,一开始1,3案例一直错,原来输入可能是无序的,即 子节点可能先于父节点给出 

分析:用vector存储每个节点的子节点,再用队列遍历每个节点,用vector的size()判断是否有子节点,f数组存每个节点的层次,value数组存每个层次没有子节点的节点个数

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
int main(){
    int n,m;
    while(cin>>n && n){
    	cin>>m;
    	int f[105],value[105],top=0;
    	memset(f,0,sizeof(f));
    	memset(value,0,sizeof(value));
    	vector<int> v[105];
    	queue<int> q;
    	q.push(1);
    	for(int i=1;i<=m;i++){
    		int id,k;
    		cin>>id>>k;
    		for(int j=1;j<=k;j++){
    			int temp;
    			cin>>temp;
    			v[id].push_back(temp);
			}
		}
		while(!q.empty()){//下面变动的两句原本在输入的地方直接进行,后来发现输入可能无序,改到下面
			int root=q.front();
			q.pop();
			top=max(top,f[root]);//变动的第一句
			if(v[root].size()==0){
				value[f[root]]+=1;
			}
			for(int i=0;i<v[root].size();i++){
				q.push(v[root][i]);
				f[v[root][i]]=f[root]+1;//变动的第二句
			}
		}
		for(int i=0;i<=top;i++){
			cout<<value[i];
			if(i<top){
				cout<<" ";
			}
		}
		cout<<endl;
	}
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值