1127 ZigZagging on a Tree (30 分)(利用后序中序求层序变形)

1127 ZigZagging on a Tree (30 分)

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in "zigzagging order" -- that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.

zigzag.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1

Sample Output:

1 11 5 8 17 12 20 15

先利用后序和中序求出树,之后层序得到一个数组,然后利用广搜原理。。求每一层有多少个节点。over

代码:

#include<bits/stdc++.h>
using namespace std;
int n,post[100],in[100],fr[100];
int size[100]; //初始化都是0; 
struct node
{
	int data;
	node* left;
	node* right;
	int hei;
	node(){
		hei = 1;
	}
}*tree;
struct node * BuildTree(int il, int ir, int pl, int pr, int in[], int post[])
{
	if(il > ir || pl > pr)
		return NULL;
	int pos;
	for(int i = il; i <= ir; i++)
	{
		if(in[i] == post[pr])
		{
			pos = i;
			break;
		} 
	}   //找到中间节点 
	struct node* tree = new node();
	tree->data = in[pos];          
	tree->left = BuildTree(il, pos - 1, pl, pl + (pos - il) - 1, in, post);
	tree->right = BuildTree(pos + 1, ir, pl + (pos - il), pr - 1, in, post);
	return tree;
}
int FloorOrder(struct node* tree){
	queue<node*>qu;
	qu.push(tree);
	int now = 0 ;
	int maxn = -0x3f3f3f3f;
	while(qu.empty() == 0)
	{
		struct node* gg = qu.front();
		qu.pop();
		size[gg->hei]++;
		maxn = max(maxn,gg->hei);
		fr[++now] = gg->data;
		if(gg->left) 
		{
			gg->left->hei = gg->hei + 1;
			qu.push(gg->left);	
		}	
		if(gg->right)
		{
			gg->right->hei = gg->hei + 1;
			qu.push(gg->right);
		}	
	}
	return maxn;
}
int main()
{
	scanf("%d", &n);
	for(int i = 1; i <= n ; i ++ )
		scanf("%d",&in[i]);
	for(int i = 1; i <= n ; i ++)
		scanf("%d", &post[i]);
	tree = BuildTree(1, n, 1, n, in, post);
	int kk = FloorOrder(tree);//层序的ok了 现在就差知道每一层有多少个节点了 
	int flag = 0,sum = 0;
	for(int i = 1 ; i <= kk; i++)
	{
		if(flag == 0){
			int j = sum + size[i];
			while(j > sum){
				printf("%d%c",fr[j]," \n"[i == kk && j == sum + 1]);
				j--;
			}
		}else 
		{
			for(int j = sum + 1; j <= sum + size[i]; j++)
				printf("%d%c",fr[j]," \n"[i == kk && j == sum + size[i]]);
		}
		sum = sum + size[i];
		flag = !flag;
	}	
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值