1127 ZigZagging on a Tree (30 分)——甲级(二叉树蛇形输出)

16 篇文章 0 订阅

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in “zigzagging order” – that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.
在这里插入图片描述
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1
Sample Output:
1 11 5 8 17 12 20 15

题目大意:给定二叉树的后序和中序,蛇形输出其层序:如果是偶数层,则从右往左输出;否则,从左往右输出。
思路:建树—>bfs存层序结果—>求出每层节点数—>扫描结果数组,顺序输出对应层应该输出的顺序

代码如下:

#include <iostream>
#include <cstdio>
#include <queue>
#include <vector>
#include <algorithm>
using namespace std;
typedef struct node* tree;
vector<int>v;//存中序结果
struct node
{
    int data;
    tree left;
    tree right;
};
int post[35], in[35], sum[30];//sum[]存每层的节点数
tree build(int postl, int postr, int inl, int inr)
{
    if(postl > postr) return NULL;
    int i = inl;
    while(i<inr && post[postr]!=in[i]) i++;
    int sum = i-inl;
    tree t = new node;
    t->data = post[postr];
    t->left = build(postl, postl+sum-1, inl, i-1);
    t->right = build(postl+sum, postr-1, i+1, inr);
    return t;
}
void bfs(tree t, int n)
{
    queue<tree>q;
    q.push(t);
    v.push_back(t->data);
    while(!q.empty())
    {
        tree x = q.front();
        if(x->left)
        {
            q.push(x->left);
            v.push_back(x->left->data);
        }
        if(x->right)
        {
            q.push(x->right);
            v.push_back(x->right->data);
        }
        q.pop();
    }
}
void dfs(tree t, int depth)//求每层节点数
{
    if(!t) return ;
    sum[depth]++;
    dfs(t->left, depth+1);
    dfs(t->right, depth+1);
}
int main()
{
    int n;
    cin >> n;
    int i, j;
    for(i=1; i<=n; i++) cin >> in[i];
    for(i=1; i<=n; i++) cin >> post[i];
    tree t = NULL;
    t = build(1, n, 1, n);
    bfs(t, n);
    dfs(t, 0);
    cout << v[0];
    int depth = 0;//从第0层开始
    for(i=1; i<v.size(); i+=sum[depth])
    {
        depth++;
        if(depth%2 == 1)
        {
            for(j=0; j<sum[depth]; j++)
                cout << " " << v[i+j];
        }
        else
        {
            for(j=sum[depth]-1; j>=0; j--)
                cout << " " << v[i+j];
        }
    }
    cout << endl;
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值