L2-006 树的遍历 (25 分)

L2-006 树的遍历 (25 分)

给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数N(≤30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

输出样例:

4 1 6 3 5 7 2

后序中序输出前序

#include<bits/stdc++.h>
using namespace std;
int n;
struct node{
	int data;
	struct node *left;
	struct node *right;
}*root;
vector<int> vec;
int por[35],in[35];
struct node *InPorToPre(int in[], int por[],int il,int ir, int pl, int pr)
{
	if(pl > pr || il > ir)
		return NULL;
	int pos;
	for(int i = il; i <= ir; i++)
	{
		if(in[i] == por[pr])
		{
			pos = i;
			break;
		}
	}
	struct node* root = new node();
	root->data = por[pr];
	root->left = InPorToPre(in,por,il,pos - 1,pl,pos - il + pl - 1); 
	root->right = InPorToPre(in,por,pos + 1,ir,pos - il + pl,pr - 1); 
	return root;
}

void LevelOrder(struct node*root)
{
	queue<node*>qu;
	qu.push(root);
	vec.push_back(root->data);
	while(qu.empty() == 0)
	{
		struct node * tmp = qu.front();
		qu.pop();
		if(tmp->left)
		{
			qu.push(tmp->left);
			vec.push_back(tmp->left->data);
		}
		if(tmp->right)
		{
			qu.push(tmp->right);
			vec.push_back(tmp->right->data);
		}
	}
	return;
}
int main(){
	int n;
	scanf("%d",&n);
	for(int i = 1; i <= n; i ++)
		scanf("%d",&por[i]);
	for(int i = 1; i <= n; i ++)
		scanf("%d",&in[i]);
	root = InPorToPre(in,por,1,n,1,n); 
	LevelOrder(root);
	for(int i = 0 ; i < n; i ++)
		printf("%d%c",vec[i]," \n"[i == n - 1]);
	return 0;
} 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值