L2-006 树的遍历 (25分) 【二叉树 + BFS】

根据给定的二叉树后序和中序遍历序列,重构并输出其层序遍历序列。题目提供输入样例,包括结点数量及两个遍历序列,要求输出层序遍历结果,各数字间以空格分隔。
摘要由CSDN通过智能技术生成

给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。
输入格式:

输入第一行给出一个正整数N(≤30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。
输出格式:

在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。
输入样例:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

输出样例:

4 1 6 3 5 7 2

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <queue>
using namespace std;

const int maxn = 1e4 + 10;
struct node{
	int l, r;
}tree[maxn];
int las[maxn];
int mid[maxn];
int n;

void build(int las_l, int las_r, int mid_l, int mid_r) {
	if(las_l >= las_r)	return;
	int id = mid_l;
	while(mid[id] != las[las_r])	id++;
	int l_len = id - mid_l, r_len = mid_r - id;
	int las_lson_end = las_l - 1 + l_len;
	int las_rson_end = las_r - 1;
	if(l_len > 0)
		tree[mid[id]].l = las[las_lson_end];
	if(r_len > 0)
		tree[mid[id]].r = las[las_rson_end];
	build(las_l, las_lson_end, mid_l, mid_l - 1 + l_len);
	build(las_l + l_len, las_rson_end, id + 1, mid_r);
}

void bfs() {
	int id = las[n];
	queue<int>que;
	que.push(id);
	while(!que.empty()) {
		int cur = que.front();
		que.pop();
		cout << cur;
		if(tree[cur].l != 0)	que.push(tree[cur].l);
		if(tree[cur].r != 0) 	que.push(tree[cur].r);
		if(!que.empty())	cout << " ";
	}
}

int main() {
	cin >> n;
	for(int i = 1; i <= n; i++)	cin >> las[i];
	for(int i = 1; i <= n; i++)	cin >> mid[i];
	build(1, n, 1, n); 
	bfs();
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值