ACM ProblemN

 我现在做的是编号为1013的试题,题目内容如下所示:

Problem N

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 40   Accepted Submission(s) : 20
Problem Description
Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc.
All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite.

Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.
 

Input
Input is a sequence of lines, each containing two positive integers s and d.
 

Output
For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.
 

Sample Input
  
  
59 237 375 743 200000 849694 2500000 8000000
 

Sample Output
  
  
116 28 300612 Deficit 简单题意:Ms公司每五个月进行财务统计,但每次统计都是亏损,通过计算计算出公司的盈余情况,如果是赚的话,则输出所赚金额,如果是亏损的话,则输出
Deficit


解题思路:首先要保证每次统计是处于亏损状态,而且也要尽可能的保证最后赚更多的钱。第一次统计是从第五个月开始统计的,以后每个月都要进行统计,刚一开始默认每个
月都是盈利的,然后从这统计的五个月的最后一个月变成亏损的,直到最后使得这五个月处于亏损状态,之所以要从后面变成亏损,是保障下一次统计时处于亏损状态,而不必
要进行过多的进行亏损赋值,最后统计处于亏损状态的月份个数,同时,也能得到赚钱的月份,计算这一年是赚钱还是亏钱。




编写代码:
#include <iostream>
using namespace std;

int countNum(int a, int b, bool month[12])
{
    int count = 0;
    for (int j=a; j<b; j++)
        if(month[j] == false)
          count++;
    return count;
}
int main()
{
    int s, d;
    while ( cin >> s >> d)
    {
      bool month[12];
      for (int i=0; i<12; i++)
      {
        month[i] = true;
      }
      int counts = 0;
      int countd = 0;
      for (int i=0; i<=7; i++)
      {
        countd = countNum(i, i+5, month);
        counts = 5 - countd;
        while (countd * d <= counts * s)
        {
                for (int j=i+4; j>= 0; j--)
                {
                    if (month[j] == true)
                    {
                       month[j] = false;
                       break;
                    }
                }
                countd = countNum(i, i+5, month);
                counts = 5 - countd;
        }
      }
      countd = countNum(0, 12, month);
      counts = 12 - countd;
      int money = counts * s - countd * d;
      if (money > 0)
        cout << money << endl;
      else
        cout << "Deficit" << endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值