acm_problem_1013

题目描述:

Problem Description
Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc.
All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite.

Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.
 

Input
Input is a sequence of lines, each containing two positive integers s and d.
 

Output
For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.
 

Sample Input
  
  
59 237 375 743 200000 849694 2500000 8000000
 

Sample Output
  
  
116 28 300612 Deficit
 

大意:公司一年中无论哪个连续的五个月都是亏的,让求最大能盈利多少。。


想法:可以分几种情况,看看输入的数据满足哪种情况,依次五个月中亏1个月,两个,三个,四个。。然后用if else语句就可以算出来。。


代码:

#include <iostream>

using namespace std;
int main()
{
    int s,d,W;
    while((cin>>s)&&(cin>>d))
    {
        if(d>4*s)
            W=10*s-2*d;
        else if(2*d>3*s)
            W=8*s-4*d;
        else if(3*d>2*s)
            W=6*s-6*d;
        else if(4*d>s)
            W=3*s-9*d;
        else W=-1;
        if(W<0)
            cout<<"Deficit"<<endl;
        else
            cout<<W<<endl;
    }
    return 0;

}

感想:一开始惯性思维第四个if语句写成4*s-8*d了,后来找了老长时间才找到,做题一定要细心。。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值