ACM 1042题 N!

N!

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 88969    Accepted Submission(s): 26266



Problem Description
Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!
 

Input
One N in one line, process to the end of file.
 

Output
For each N, output N! in one line.
 

Sample Input
 
 
123
 
Sample Output
 
 
126
 

Author
JGShining(极光炫影)


注意:

    求阶层的变量要从1开始,而不是从0开始


题目地址http://acm.hdu.edu.cn/showproblem.php?pid=1042


import java.util.*;
import java.math.*;

public class Main extends Object {

	public static final Scanner cache = new Scanner(System.in);

	public static void main(String[] args) {

		while (cache.hasNext()) {

			long n = cache.nextLong();
			BigInteger sum = new BigInteger("1");

			for (long x = n; x > 0; x--) {
				sum = new BigInteger(String.valueOf(x)).multiply(sum);
			}
			System.out.println(sum.toString());

		}

	}

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值